summaryrefslogtreecommitdiff
path: root/dev-python/sabctools/sabctools-8.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
commitf85858c81a721c7fc89c1ab8df19e3a213dc27cd (patch)
tree3f0aeb33e434ee50b99bcc8b54158bc6169a41f2 /dev-python/sabctools/sabctools-8.2.4.ebuild
parent16857b69f990738d17bc5842e3e49a6e82d1428d (diff)
gentoo auto-resync : 18:07:2024 - 12:29:01
Diffstat (limited to 'dev-python/sabctools/sabctools-8.2.4.ebuild')
-rw-r--r--dev-python/sabctools/sabctools-8.2.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sabctools/sabctools-8.2.4.ebuild b/dev-python/sabctools/sabctools-8.2.4.ebuild
new file mode 100644
index 000000000000..5660f5098ba9
--- /dev/null
+++ b/dev-python/sabctools/sabctools-8.2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest