summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild
new file mode 100644
index 000000000000..8f91a41a40c7
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.16.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="https://pypi.org/project/ruamel.yaml/ https://sourceforge.net/p/ruamel-yaml"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}