summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild')
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
index c9e2b1556ab8..2b49051b9e24 100644
--- a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1 vcs-snapshot
+MY_PN="${PN//-/.}"
+
DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
HOMEPAGE="https://pypi.org/project/ruamel.std.pathlib/ https://bitbucket.org/ruamel/std.pathlib"
-MY_PN="${PN//-/.}"
SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -17,10 +18,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 ~x86"
IUSE="test"
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_4)
-"
+RDEPEND=""
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -30,11 +28,11 @@ DEPEND="
)
"
+python_test() {
+ py.test -v _test/test_*.py || die
+}
+
python_install() {
distutils-r1_python_install --single-version-externally-managed
find "${ED}" -name '*.pth' -delete || die
}
-
-python_test() {
- py.test -v _test/test_*.py || die
-}