summaryrefslogtreecommitdiff
path: root/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild')
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
deleted file mode 100644
index 742c3574f6e2..000000000000
--- a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
-HOMEPAGE="https://pypi.org/project/ruamel.std.pathlib/ https://bitbucket.org/ruamel/std.pathlib"
-MY_PN="${PN//-/.}"
-SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="test"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python3_4)
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}
-
-python_test() {
- py.test -v _test/test_*.py || die
-}