summaryrefslogtreecommitdiff
path: root/dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 21:25:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 21:25:57 +0100
commitcd25c8de05c7dc4ab208846c70ef68ab015f9342 (patch)
tree06b04b6bbe579240273d10fde11b808a63a0bc2a /dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild
parent7a96f048f69e32c7410aefdabff0c61f9052ac77 (diff)
gentoo auto-resync : 07:08:2023 - 21:25:57
Diffstat (limited to 'dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild')
-rw-r--r--dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild b/dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild
new file mode 100644
index 000000000000..70552bc72cd1
--- /dev/null
+++ b/dev-python/rtslib-fb/rtslib-fb-2.1.76.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="A Python object API for managing the Linux LIO kernel target"
+HOMEPAGE="
+ https://github.com/open-iscsi/rtslib-fb/
+ https://pypi.org/project/rtslib-fb/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ # super basic import test
+ "${EPYTHON}" - <<- EOF || die "Failed tests with ${EPYTHON}"
+ from rtslib_fb import RTSRoot
+ EOF
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/target.service"
+}