summaryrefslogtreecommitdiff
path: root/dev-python/rst-linker
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/rst-linker
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/rst-linker')
-rw-r--r--dev-python/rst-linker/Manifest2
-rw-r--r--dev-python/rst-linker/rst-linker-2.1.1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index ffa178948113..afd204411b64 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1,3 +1,5 @@
DIST rst.linker-2.0.0.tar.gz 12861 BLAKE2B f52ddab3c8119f0bac64e294e4a5a3cc50916f19f49ca1ca4983d8b5d2bb5401c6accb5873df38609386e12fcd1cb02b867f3633edd4d10606a98936e96e62eb SHA512 ea9fa95de66c95dc384c888446512be66b180d0d76e99fe7a6b8f8348436d4be959d3d567fa521d9fc925b537467a4fdf05f9e9d17f7a6df4aafd6dfd323e4fc
+DIST rst.linker-2.1.1.tar.gz 13492 BLAKE2B 0f53f3110c4a54e7eb36787ed08f81d0ce551174251203b7184ccbcc0153ee450e8e8927e8989b572b929219b1002019f49167482d59956ad96a54360317f998 SHA512 c49e6b3de41636184f75941d8fa258c2dad3d13a7d82b6221a10f583ada228a96f56abefce7840f93cbae8512332b69430601961cc396f3917b912e369b2b1b9
EBUILD rst-linker-2.0.0.ebuild 1304 BLAKE2B 3fdfa210eed10fdfb45cb2ec50ce12c82e89ce683d397294f85bbf08c9a56becfb3b4cf4d8c86a31786d0108400466302bca1d7b2d902128916a4db669b475ec SHA512 bc9cf9c4d2483feba77e728ddbac88f1ecea073679de347f49c1ff2ec9aee9289d5638a437613aacfe2e65847ac9094f45614efc72a952703f86eee0699b7b82
+EBUILD rst-linker-2.1.1.ebuild 1243 BLAKE2B 4bf113816aae62bfd481401d144e1bdad99162a167b6f363f75161d3708e15e77c6f83c52d04d7cd82705df853d7b70418c43cf898e2bd134a1b0540a8d31d97 SHA512 25657d1431b54af2cc3b99cc207ef5608d823c96060cd25849383aa6b0622c7955923f1c7e38b30a75d993fc05f68f9891d22f60d5752931ae8c25d299edbd91
MISC metadata.xml 464 BLAKE2B 553b3e9fd8b0a5df09e6ff044ecc6724c155bff6ea5ce21ceb1cbf919e1dee65122f8902921235a40b20baf656a54861741633dfa853405785d8ceecdf0c37b3 SHA512 cb0e45d357d9134fda6c859885350414a04ba45d8a5bbf4424f3f4311f0e662aefce70238434392d8be98b0d7ecb6c470f6725935143e88e09463ff3f0519f02
diff --git a/dev-python/rst-linker/rst-linker-2.1.1.ebuild b/dev-python/rst-linker/rst-linker-2.1.1.ebuild
new file mode 100644
index 000000000000..f893fc98c94b
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="https://github.com/jaraco/rst.linker"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs ">=dev-python/jaraco-packaging-3.2"
+distutils_enable_tests pytest
+
+python_test() {
+ # Ignore the module from ${S}, use the one from ${BUILD_DIR}
+ # Otherwise, ImportMismatchError may occur
+ # https://github.com/gentoo/gentoo/pull/1622#issuecomment-224482396
+ # Override pytest options to skip flake8
+ pytest -vv --ignore=rst --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}