summaryrefslogtreecommitdiff
path: root/dev-python/rst-linker/rst-linker-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
commit21dbcce41990b13f301240313be05c8d013a9258 (patch)
tree933b3c51d46dc15fefe62b03a4f41c85b7e9bb44 /dev-python/rst-linker/rst-linker-2.4.0.ebuild
parente53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (diff)
gentoo auto-resync : 28:01:2023 - 08:51:03
Diffstat (limited to 'dev-python/rst-linker/rst-linker-2.4.0.ebuild')
-rw-r--r--dev-python/rst-linker/rst-linker-2.4.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/rst-linker/rst-linker-2.4.0.ebuild b/dev-python/rst-linker/rst-linker-2.4.0.ebuild
new file mode 100644
index 000000000000..af00fd4c42e9
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="
+ https://github.com/jaraco/rst.linker/
+ https://pypi.org/project/rst.linker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/path[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest