summaryrefslogtreecommitdiff
path: root/dev-python/rsa/rsa-4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-22 02:45:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-22 02:45:48 +0100
commit52fc263f2dd029a99ad4f0e5e1c3dbfd490d6b63 (patch)
treef00cbd5f2bd3b202f000a03fb3beb1742890f144 /dev-python/rsa/rsa-4.9.ebuild
parentaa870ba91722a8d38ba5103297a6aa4abb54e5bc (diff)
gentoo auto-resync : 22:07:2022 - 02:45:47
Diffstat (limited to 'dev-python/rsa/rsa-4.9.ebuild')
-rw-r--r--dev-python/rsa/rsa-4.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rsa/rsa-4.9.ebuild b/dev-python/rsa/rsa-4.9.ebuild
new file mode 100644
index 000000000000..a75385ddf3e9
--- /dev/null
+++ b/dev-python/rsa/rsa-4.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-rsa-version-${PV}
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="
+ https://stuvel.eu/rsa/
+ https://github.com/sybrenstuvel/python-rsa/
+ https://pypi.org/project/rsa/
+"
+SRC_URI="
+ https://github.com/sybrenstuvel/python-rsa/archive/version-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ rm tests/test_mypy.py || die
+ distutils-r1_src_prepare
+}