summaryrefslogtreecommitdiff
path: root/dev-python/rq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/rq
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest3
-rw-r--r--dev-python/rq/metadata.xml11
-rw-r--r--dev-python/rq/rq-0.13.0.ebuild19
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
new file mode 100644
index 000000000000..c4d1c1415f15
--- /dev/null
+++ b/dev-python/rq/Manifest
@@ -0,0 +1,3 @@
+DIST rq-0.13.0.tar.gz 45487 BLAKE2B 1985a097d419b50b19771a5f1c1526c8b8b3e9b960f7ecb2817cd731a9af0c37dd38e215a556d35ae8107cc93c3da9c023d4e73eda90e776d62a994d74f5bbda SHA512 f8cf5c3cf7360e0640a2ca97a42c85e67e59835317d04dc752008463224e073053c70ede17e179e1e8d287b3e4ed832971a0398636c49e2680f1183f0ebd2302
+EBUILD rq-0.13.0.ebuild 517 BLAKE2B 43e42a588fc0ce20d86e0b5feed41504288b6d4db77c8a27185a849d872658adc77d3af8fb207b210ef7e1d9895f075f28186ce52a534b4478df362caf445433 SHA512 8fc44fcd6cdea706be024d5975e004603b4ebab7345018bf959572cc8004fd4e58330c84e4a743f5bc45f3e6a3b319aa8bd53d1bfd4539285a2dd2d4187d02ae
+MISC metadata.xml 327 BLAKE2B d4518f6d7090440fec7e9518fbce9813be8c9e7bce9583bdf0c47b1ca456a078d23fea12f20febd4f4bad6d2e57109e5acf301bdf724c6cdb5346749a3e42989 SHA512 88bc51ba0079d132b0bf9b053e33262f5cae9c4a66f561d6c7303066f117e2196fbbfbce5b4cfe35c7f1cc5020b3818c365dab4dde696d5543dc70ca32d40ff1
diff --git a/dev-python/rq/metadata.xml b/dev-python/rq/metadata.xml
new file mode 100644
index 000000000000..5d3d9dc0e2ac
--- /dev/null
+++ b/dev-python/rq/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/rq/rq-0.13.0.ebuild b/dev-python/rq/rq-0.13.0.ebuild
new file mode 100644
index 000000000000..e0b65c4fd2d5
--- /dev/null
+++ b/dev-python/rq/rq-0.13.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://github.com/rq/rq"
+SRC_URI="mirror://pypi/${PN:0:1}"/${PN}/${P}.tar.gz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"