summaryrefslogtreecommitdiff
path: root/dev-python/rq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
commitb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (patch)
tree4fcc91b967ba153d4030d61e10f1b07b53755488 /dev-python/rq
parent2d3042634af4767714cb90eff3f773ef54afb5ed (diff)
gentoo auto-resync : 29:05:2023 - 09:16:49
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.15-r1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index e9027a254fa9..7316ae5bce0b 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -5,5 +5,6 @@ DIST rq-1.15.gh.tar.gz 633276 BLAKE2B 885b4ef343924b8f4a88c6c3e93bbed1b62022e722
EBUILD rq-1.13.0.ebuild 1401 BLAKE2B 4fa72ab225622213cf46207cd8ced06faf4be6e67bfaa24f4a6107de3cf90a8a804c74d9b31cdcacd16cb3d1bdc0add6ebf5e39fd83a4ef2c0d0a7d3560b0281 SHA512 b719e2538d10d7b71c1d91132965d839ae688a396f3535db065c9c2ffaf7dc5e0725272acd86adcddbb3e803583ea8b3ef8e21a4b56c47d72785cbd2237e345d
EBUILD rq-1.14.1.ebuild 1447 BLAKE2B b139b20c73be2e56b82f20cfa30dcf166eb23d02fdb95226eac7ff79ed23b56705f148629dae7dbb628152b346db6d2175b7ebd05a966262e57dc5da00207c01 SHA512 7e781a8cc32f3fff0260d6dc4b12e9f2e3b88e09fd5fdf62e4f6697c055347265aaa25fc212bcdae4ab054c473ffa8d8603ad7c57f5f90096384d019f0d76dc8
EBUILD rq-1.14.ebuild 1447 BLAKE2B e07a3b74e72ce85b03c73fb549940d3f8252a4014b86bd400b7487a975ccac42d3b8ec442dade3ef5792ae332e223fcd93b2c88598c17259378d05c4d81c09f8 SHA512 03dfcf71b23e6688098ff22f4051350312e0ff8961d1547ad2b8d81d28f32777b872243230952a2b4a64ef920f20cf8c704f82ce5cc254d1ff9dc4f4a4c2aba3
+EBUILD rq-1.15-r1.ebuild 1441 BLAKE2B 7abf8e40a520fd49e1f90198a212e242ddf83ebf6c43ae806e0516cbbe3fbabfb1b279b0698195793033ad1629b43702902a30ca8d83b31265d80f8b9e6a7e97 SHA512 e1921bff061bea32d5facaa128140530f9d21117f03aae0d9df7f29193a2d897f40328c80eaf80ed4685b19363935b040c544bead2be5d3c107a885d1ee11d97
EBUILD rq-1.15.ebuild 1447 BLAKE2B dc02a1685f96ef33bdc088032b033fa3b7fd712bf1a891703d3491d9716c23273acbba88dcd2360aec0a8d42262870dad08b5bcd15a5074e6e2816fe4a621889 SHA512 cd79cb058fe8980923e0d5062f3f40039c59f008accdffafd7908d25dc2628b5bc9e476b9d3f6874ca5a0ba0e52dac58a75ba2a4bfa306245b6e6cf637e4641f
MISC metadata.xml 453 BLAKE2B 6a46d43b524fded1ad4749fb9669ea07f8b3e23940d0bf2a4db5d92564316b01fdfbe220771e30b1a110ef72c613ad683cdcb7940682ea32198a5b6f027e4db3 SHA512 104ef96c34b55a9fda377c1304ff85781219fdbccef1a83d1bef30cb2fbd0ef816cfe82715af8937f452499135f7ed65c65a29c34919a09b6144ada367c26af5
diff --git a/dev-python/rq/rq-1.15-r1.ebuild b/dev-python/rq/rq-1.15-r1.ebuild
new file mode 100644
index 000000000000..8c0bd028f82f
--- /dev/null
+++ b/dev-python/rq/rq-1.15-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_11 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+# Tests missing from sdist, as of 1.14.1
+SRC_URI="
+ https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}