summaryrefslogtreecommitdiff
path: root/dev-python/rq/rq-1.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 08:19:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 08:19:52 +0000
commit0e2545bd942206b16391a6d7a256a5ef3ef497e7 (patch)
tree150f1f075f8a1fcc79cfec68d157b7c4979ce405 /dev-python/rq/rq-1.13.0.ebuild
parent8dd17625671faf6a47abf31d4c96a1e20d764ba5 (diff)
gentoo auto-resync : 20:02:2023 - 08:19:52
Diffstat (limited to 'dev-python/rq/rq-1.13.0.ebuild')
-rw-r--r--dev-python/rq/rq-1.13.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/rq/rq-1.13.0.ebuild b/dev-python/rq/rq-1.13.0.ebuild
new file mode 100644
index 000000000000..7483126181b1
--- /dev/null
+++ b/dev-python/rq/rq-1.13.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+SRC_URI="
+ https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-3.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}