summaryrefslogtreecommitdiff
path: root/dev-python/rpyc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
commit704343381e435b306648a2d85a77a58e34478643 (patch)
tree009e24c29e03885a4bd7bb17b673f62567395237 /dev-python/rpyc
parenteb147001d2176fe9850e42017a6b1284baf865ff (diff)
gentoo auto-resync : 29:10:2023 - 09:35:42
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest1
-rw-r--r--dev-python/rpyc/rpyc-5.3.1-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 9821f8801bf8..b94165e72e49 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,4 +1,5 @@
AUX rpyc-5.3.0-no-gevent.patch 1241 BLAKE2B 44b0584b90aa4730998dd9c44430edbb0348f581b930ce1663b4dc7105c6fafccd1d73c2850892ec7898f678bc57de592dcec1af4615778919b97a15fc9d56ca SHA512 d057255548f94c433d2e6f064d9db33caf7909ae17a9eddaabb2f87560f31a6b9e94c0470b78fab7aca15c6c96b6a8c2cf96d92d57d9925d5616c7454f823326
DIST rpyc-5.3.1.gh.tar.gz 1271046 BLAKE2B b7c86aa5cf774d306b2d6fdbac97441533bc5a847aaf03c11b0abf0a07587a2f7d081470d3402fde4251ea6654051d96983feefa2ba7e65a9a95d76f179edcad SHA512 a328903c336483f7110cbbff96173ba0b5ae6cf16f6306c624055bd631d914772c42dcfcf48a275b7dc53241f6b10a397ee49f17b8a3c3c8dbee8f42ac784465
+EBUILD rpyc-5.3.1-r1.ebuild 2051 BLAKE2B c1049b994331c51e887a093014b9fdbe22dfd1deddbaeff8b39eb7e125e7af55d33b1677f3b68a0a90615dfc116139a7fc2587c4d353e2bdbde8bb0e18fb8d4c SHA512 fb5ae5b95f842d8e4b2902acf6e2e34a25511a0c4d226cdf5e792836e8f4a3fba900a86777d744f16323418653747c1c4490b8d009f04ec65c5c1bfe0279eefa
EBUILD rpyc-5.3.1.ebuild 2049 BLAKE2B 5af9bec7f2e314d6a0fba6626cecd3c2b0f4ee93d1b54d0aa9d226311477aaf474424ea8db1a763ced1c3e509fc0a11e48d1c69a13700b0c3fd7108d40fd227b SHA512 93151d6ab91ac7d8e886fa7606b97483a5aab74dc90fbc935864482b9bc98468f74bac039d6c4c363218e7f70c4577491ca1891cc00ef7a530dc026447219b3c
MISC metadata.xml 654 BLAKE2B f84ea5b5fb66c2661bdcbed8566a77c872b6f1b3a6b0cb021269657b21fd414e70edf03f205ee2038d9d83a20e25d32b15760d915b98066aa7fe1a4cfeb3bd16 SHA512 6ea40af97501443c8d4ae783137bb9547c5a4cc3685c01b9d684691d110f67eb43056acfcebcc510c06fc40ff596ad9e3e30cf76cb07807f23250721e93b4954
diff --git a/dev-python/rpyc/rpyc-5.3.1-r1.ebuild b/dev-python/rpyc/rpyc-5.3.1-r1.ebuild
new file mode 100644
index 000000000000..4c2567d387f5
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.3.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://github.com/tomerfiliba-org/rpyc/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+
+CDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ dev-python/plumbum[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.3.0-no-gevent.patch )
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ # This test fails with NO_CIPHERS_AVAILABLE
+ rm tests/test_ssl.py || die "rm test_ssl.py failed"
+
+ # dev-python/gevent is being removed
+ rm tests/test_gevent_server.py || die "rm test_gevent_server.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do PYTHONPATH="${WORKDIR}"/${P}-${EPYTHON/./_}/install/usr/lib/${EPYTHON}/site-packages ${EPYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}