summaryrefslogtreecommitdiff
path: root/dev-python/rpyc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-20 13:02:32 +0000
commit65c1a6f8d7210639cbdc1565ccee4758f45dfc45 (patch)
treed7bea8e8d228e76b177eccb0ffc1f45a58a1e2f7 /dev-python/rpyc
parentc4f077d9f57bf57fcded75904bf512075191d2d2 (diff)
gentoo auto-resync : 20:11:2022 - 13:02:32
Diffstat (limited to 'dev-python/rpyc')
-rw-r--r--dev-python/rpyc/Manifest2
-rw-r--r--dev-python/rpyc/rpyc-5.2.3_p1.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/rpyc/Manifest b/dev-python/rpyc/Manifest
index 164571e92b6a..d27057b7fa77 100644
--- a/dev-python/rpyc/Manifest
+++ b/dev-python/rpyc/Manifest
@@ -1,3 +1,5 @@
DIST rpyc-5.2.3.tar.gz 1267934 BLAKE2B 3c03d587293375f875de31d6a89ba07b47bd4f4ff9fd5c7b23ed0c83e420e9d2bab08844c3538299797203ac90e7e81b955db02de70bf1cee5ea59d8475a6848 SHA512 4be189a719be100886e08d9c2c0769d12b7d1c5e167c197ebee1a3db542e228f2124fea976e5af3680136b298ce4632c79b2f302128dff31ebf45dcf52a9743f
+DIST rpyc-5.2.3_p1.tar.gz 1269198 BLAKE2B 288568fcd34787850968d4e3fd9ca7c2d29e506f1331b746104760e678dfef43fd30b08f68b3bdda6df84d488f88dc76cfdd23d5a5ad0a4cefeab468ac6a1b0b SHA512 4b29899a51364779185d2b56f5d5ee4c650c40b8322e5594500222fdcec85414cdbabd41437467e2ff73124a79e8c9cde23dfe89138abb935732ccaba69de2bb
EBUILD rpyc-5.2.3-r3.ebuild 2089 BLAKE2B 3d33a3520dca7ef1bbdfb477548e943ef76aee15bc8bf0f9e713d7108875e46d6ee5d9bb9d4610934a869a441a67a320889d0131c032351a9e963a077294640b SHA512 ada7525c16934719dd52ee96bce609d2831883a55bc544be8fe7ff341322a4ae21601e696c3ef5e8b4cac3468e9903e7b9155b1223b68c32dfce5f5c7d6aa8b0
+EBUILD rpyc-5.2.3_p1.ebuild 1936 BLAKE2B c79f627bc722b32027051cf245ed9263c5d53271e95f2f5c751b16bd8992cd617f35722e77ca06df5b72cee0c91c730f2e2d21623422729c42859ce53ee010a4 SHA512 6bffe86a512bb8bda622e1f7ef04cabc1d44f865a9fb8bc00f4259e85e985236f8f733c98870b93e348286a62a0a3b31c8b337870c0e48a3907c727b87cf89b7
MISC metadata.xml 736 BLAKE2B d6f6d76b5118e6f8aef119b975572ba95875f89bc2a4b2bb072e1b1ccccfb4593845e16ea0c62a4436ce419a3792b89b7a995c36a2ce979cf85db0dbd5f6754f SHA512 7714c32ffeb31611fe41d2ec674b774fdd46b137a90bb52245b1dcc229f2577739d33d61788ec123cce0c4dec3da49a19fdcc4eb307ea3af26ae8c4195bb0d93
diff --git a/dev-python/rpyc/rpyc-5.2.3_p1.ebuild b/dev-python/rpyc/rpyc-5.2.3_p1.ebuild
new file mode 100644
index 000000000000..31fe074b28ed
--- /dev/null
+++ b/dev-python/rpyc/rpyc-5.2.3_p1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/
+ https://pypi.org/project/rpyc/
+ https://github.com/tomerfiliba-org/rpyc"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# USE flags gdb, numpy are used *only* to run tests depending on these packages
+IUSE="test numpy gdb"
+RESTRICT="!test? ( test )"
+
+CDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] dev-python/pandas[${PYTHON_USEDEP}] )
+ gdb? ( sys-devel/gdb )"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ dev-python/plumbum[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+
+ # Windows specific test
+ rm tests/test_win32pipes.py || die "rm tests/test_win32pipes.py failed"
+
+ # These tests require running sshd
+ rm tests/test_ssh.py tests/test_deploy.py || die "rm test_ssh.py test_deploy.py failed"
+
+ # This test requires internet access
+ rm tests/test_registry.py || die "rm test_registry.py failed"
+
+ # This test fails with NO_CIPHERS_AVAILABLE
+ rm tests/test_ssl.py || die "rm test_ssl.py failed"
+
+ # dev-python/gevent is being removed
+ rm tests/test_gevent_server.py || die "rm test_gevent_server.py failed"
+
+ if ! use numpy
+ then rm tests/test_service_pickle.py || die "rm test_service_pickle.py failed"
+ fi
+
+ if ! use gdb
+ then rm tests/test_gdb.py || die "rm test_gdb.py failed"
+ fi
+}
+
+python_test() {
+ # for some reason, when tests are run via pytest or nose, some of them hung
+ pushd tests > /dev/null || die "pushd tests failed"
+ for x in test_*.py
+ do PYTHONPATH="${WORKDIR}"/${P}-${EPYTHON/./_}/install/usr/lib/${EPYTHON}/site-packages ${EPYTHON} ${x} || die "${x} failed"
+ done
+ popd > /dev/null
+}