summaryrefslogtreecommitdiff
path: root/dev-python/routes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/routes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/routes')
-rw-r--r--dev-python/routes/Manifest3
-rw-r--r--dev-python/routes/metadata.xml11
-rw-r--r--dev-python/routes/routes-2.4.1.ebuild55
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/routes/Manifest b/dev-python/routes/Manifest
new file mode 100644
index 000000000000..355eda5350a9
--- /dev/null
+++ b/dev-python/routes/Manifest
@@ -0,0 +1,3 @@
+DIST Routes-2.4.1.tar.gz 182403 BLAKE2B 21a079616e1533af8fae44b0ad428b3309e5e8d1e27dddddbf3632cb3e1f5286225aec73246012a8c7c22d59d755be27f10fa09ab6ee6b34f71c6c540dfd36e4 SHA512 b0566f10ca83af0459e9c59fa2217bdc5ebf349d944396bcb21ffa731ad189c642e409381979cb5da3153630c24f20aa974a99711f16aca9f91413976af2bb04
+EBUILD routes-2.4.1.ebuild 1558 BLAKE2B 5fc9ce2e2f102b5b8e22986eb77927ad3d7f8086c7bbe06fd70f47cd0e3e02ec3206aeb736e61e8c8710e47cddfafd9c682dd056ab755f6e4e16f23e103b5f1d SHA512 3cac12b6ca383408040c7c6ccc9fec2311516770bea6823929d34177a55e64f3c104982efa157db0583fe74e9ba38f6ac179b07328b4c9039e0fd9bc373eefa0
+MISC metadata.xml 309 BLAKE2B 58e1b02098e87fe7303e9a6ce962897750493b957d3b30f78feb58b9cbec84b5fcf80acde66da35caa71989b628a75d232ea567e679f891fb4b81d1c49f61d06 SHA512 6daa7dcc2ae185c198c2630961d68c19498e98bce96ea3b1390a4c159fb591a89af796f2ac90e00994bda52c36138792797a38975c772d6fabce09cf0536722a
diff --git a/dev-python/routes/metadata.xml b/dev-python/routes/metadata.xml
new file mode 100644
index 000000000000..7bdfdfe972fe
--- /dev/null
+++ b/dev-python/routes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Routes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/routes/routes-2.4.1.ebuild b/dev-python/routes/routes-2.4.1.ebuild
new file mode 100644
index 000000000000..89a8441f1d91
--- /dev/null
+++ b/dev-python/routes/routes-2.4.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="Routes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A re-implementation of Rails routes system, mapping URLs to Controllers/Actions"
+HOMEPAGE="https://routes.readthedocs.io/en/latest/ https://pypi.org/project/Routes/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+RDEPEND=">=dev-python/repoze-lru-0.3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+# The testsuite appears to be held back by the author
+
+S="${WORKDIR}/${MY_P}"
+
+# https://github.com/bbangert/routes/issues/42 presents a patch
+# for the faulty docbuild converted to sed stmnts
+python_prepare_all() {
+ # The default theme in sphinx switched to classic from shpinx-1.3.1
+ if has_version ">=dev-python/sphinx-1.3.1"; then
+ sed -e "s:html_theme_options = {:html_theme = 'classic'\n&:" \
+ -i docs/conf.py || die
+ else
+ sed -e "s:html_theme_options = {:html_theme = 'default'\n&:" \
+ -i docs/conf.py || die
+ fi
+ sed -e "s:changes:changes\n todo:" \
+ -i docs/index.rst || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}