summaryrefslogtreecommitdiff
path: root/dev-python/rospkg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/rospkg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/rospkg')
-rw-r--r--dev-python/rospkg/Manifest5
-rw-r--r--dev-python/rospkg/files/gentoo.patch15
-rw-r--r--dev-python/rospkg/metadata.xml11
-rw-r--r--dev-python/rospkg/rospkg-1.1.4.ebuild45
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild45
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
new file mode 100644
index 000000000000..9f7ad49e0046
--- /dev/null
+++ b/dev-python/rospkg/Manifest
@@ -0,0 +1,5 @@
+AUX gentoo.patch 662 BLAKE2B 06e1c4af66a5d1ca1e51f8d99a1cf4e62042da3d41f38b34143f7af2ec7ae4bd4516f2b57e863ec6b80d921e2ab6a920ba581dccc6615da480c237e410f4cea2 SHA512 7525f4e8809b6002000b22d6f5def37054a1bceb3d581fe01bcedd7e21dc757dd04d229e9550bfe1d2248c5804856cd9869149bea9a9ec5423e1a596c0f56153
+DIST rospkg-1.1.4.tar.gz 89554 BLAKE2B b307482cc3df0f2a178dd427a37160cfdc3c407b2135a28854f3df0ff964ed57c17a8ee358a1aa90b3d735e0913bc6c3c8ea1084efdef5fd01933166e21ebac8 SHA512 1758dcbe28c18c834a60bbda2e5e6be34629b3dd4f6519f24dfa1324ff9fc59fb7d0ae9d324c002eee06ff672309627e48f97119b36601390b24a24ae196d5c5
+EBUILD rospkg-1.1.4.ebuild 1083 BLAKE2B b4348d3a98c80a9ae1b2f41f0744c3eed3351049fbea366b3d61db65dabedb98cbee69daa7703113e54dbef8f0d70bcc5f92266b7184594173e3f4abe6c9372b SHA512 0275770022f4fb93ca1d58e196f6de84ad257f51bab066753539e1fd4f1738e4551585d83ed73546db48a631d5fddae4e50be604f7c0264049c48f8deac94929
+EBUILD rospkg-9999.ebuild 1083 BLAKE2B b4348d3a98c80a9ae1b2f41f0744c3eed3351049fbea366b3d61db65dabedb98cbee69daa7703113e54dbef8f0d70bcc5f92266b7184594173e3f4abe6c9372b SHA512 0275770022f4fb93ca1d58e196f6de84ad257f51bab066753539e1fd4f1738e4551585d83ed73546db48a631d5fddae4e50be604f7c0264049c48f8deac94929
+MISC metadata.xml 339 BLAKE2B b73b43910983a77b06481850b398f006e6e535382c5fde12e8b86d43151b840e309bb2c6b0cd83899c3a9b8fcfd1c44fe6f1e5c53008e62b5653fda7cbfb12db SHA512 c9e10c6eecb919a284258e818a9830f6ba2afe095a9f4c565bf086855d5bbb26bf6973455c62a38ab4e20eb88da1f3d44b97597b197ca30227a7e7438a84d8a7
diff --git a/dev-python/rospkg/files/gentoo.patch b/dev-python/rospkg/files/gentoo.patch
new file mode 100644
index 000000000000..5a9e7738b390
--- /dev/null
+++ b/dev-python/rospkg/files/gentoo.patch
@@ -0,0 +1,15 @@
+Strip ros_packages/ from paths. ros_packages is only for avoiding to crawl the
+whole /usr but the real one in the path without it.
+
+Index: rospkg-1.1.0/src/rospkg/rospack.py
+===================================================================
+--- rospkg-1.1.0.orig/src/rospkg/rospack.py
++++ rospkg-1.1.0/src/rospkg/rospack.py
+@@ -59,6 +59,7 @@ def list_by_path(manifest_name, path, ca
+ path = os.path.abspath(path)
+ basename = os.path.basename
+ for d, dirs, files in os.walk(path, topdown=True, followlinks=True):
++ d = d.replace('ros_packages/', '')
+ if 'CATKIN_IGNORE' in files:
+ del dirs[:]
+ continue # leaf
diff --git a/dev-python/rospkg/metadata.xml b/dev-python/rospkg/metadata.xml
new file mode 100644
index 000000000000..51380babe574
--- /dev/null
+++ b/dev-python/rospkg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-infrastructure/rospkg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rospkg/rospkg-1.1.4.ebuild b/dev-python/rospkg/rospkg-1.1.4.ebuild
new file mode 100644
index 000000000000..bf7619313e02
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
new file mode 100644
index 000000000000..bf7619313e02
--- /dev/null
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}