summaryrefslogtreecommitdiff
path: root/dev-python/ropemacs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ropemacs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ropemacs')
-rw-r--r--dev-python/ropemacs/Manifest3
-rw-r--r--dev-python/ropemacs/metadata.xml16
-rw-r--r--dev-python/ropemacs/ropemacs-0.8.ebuild31
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/ropemacs/Manifest b/dev-python/ropemacs/Manifest
new file mode 100644
index 000000000000..9fdee0b0a483
--- /dev/null
+++ b/dev-python/ropemacs/Manifest
@@ -0,0 +1,3 @@
+DIST ropemacs-0.8.tar.gz 22161 BLAKE2B f45412c37762e90615ab0ac874b8e51d211250215d1999098d5aaf56ac5c46f535128bb6935b9e8a2b86eba24baf4648893ad710c784693958bb053fc65b2fea SHA512 3e42ce03758c13d8f6e66b69a4b9ab7620956ed0272ecf770c0cea204ffae8c85f41103b29e507db7d68d6dc006b14e6ca5ce31d8ca17b6a66bf743f1110a9b3
+EBUILD ropemacs-0.8.ebuild 831 BLAKE2B 0f68ff2957b6f3715055536af94a2de67046ff4121d05ab9b2217f41c796b1d32f00af5dd0eb8c8ece21cfbaa3bb117f29b11b830947edd4f9f58547e12fd7d6 SHA512 374fd085caaadf95c0cc279775a28c6fdb310cd9ab5d5c6fc2067dc842bcf61fca4cb119e9b10bc478cc0fb201f1f9239b2f08be0a94c27a33e5e5c03260d6c7
+MISC metadata.xml 476 BLAKE2B 385516edad9299f46479406e373690e09df8a9700c850d6d75206bce2ccb3c62adf10621bf89e1cefa09d46ee7cf26478648bd6a302c8f489a325524ad3b877a SHA512 2f7eb5e71660ad51be770eee8352df5995e4599d50a43f394cb1f532444fc52be98cf6cd9e6d4ccbc1f1067ac36a66e430d1eec12de68f03e3a9d96eda7e6782
diff --git a/dev-python/ropemacs/metadata.xml b/dev-python/ropemacs/metadata.xml
new file mode 100644
index 000000000000..f3a018c56488
--- /dev/null
+++ b/dev-python/ropemacs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="pypi">ropemacs</remote-id>
+ <remote-id type="sourceforge">rope</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/ropemacs/ropemacs-0.8.ebuild b/dev-python/ropemacs/ropemacs-0.8.ebuild
new file mode 100644
index 000000000000..ae8bdf6d90a1
--- /dev/null
+++ b/dev-python/ropemacs/ropemacs-0.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils readme.gentoo
+
+DESCRIPTION="Rope in Emacs"
+HOMEPAGE="https://github.com/python-rope/ropemacs
+ https://pypi.org/project/ropemacs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1+" # GPL without version
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/rope[${PYTHON_USEDEP}]
+ dev-python/ropemode[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local DOCS="${DOCS} README.rst docs/*.rst"
+ distutils-r1_src_install
+
+ DOC_CONTENTS="In order to enable ropemacs support in Emacs, install
+ app-emacs/pymacs and add the following line to your ~/.emacs file:
+ \\n\\t(pymacs-load \"ropemacs\" \"rope-\")"
+ readme.gentoo_create_doc
+}