summaryrefslogtreecommitdiff
path: root/dev-python/rope/rope-1.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 10:15:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 10:15:54 +0000
commiteb7aa327b218d640c8bda63ba0fd1ace2bd2d17b (patch)
treebbe526e2a2c1fd2fd7ee20d62b99c7ac30476aff /dev-python/rope/rope-1.11.0.ebuild
parent6471b382a951b256ffa1b8ea3e6e7d7f5b189281 (diff)
gentoo auto-resync : 06:11:2023 - 10:15:54
Diffstat (limited to 'dev-python/rope/rope-1.11.0.ebuild')
-rw-r--r--dev-python/rope/rope-1.11.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/rope/rope-1.11.0.ebuild b/dev-python/rope/rope-1.11.0.ebuild
new file mode 100644
index 000000000000..c2536d79323e
--- /dev/null
+++ b/dev-python/rope/rope-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)