summaryrefslogtreecommitdiff
path: root/dev-python/root_numpy/root_numpy-4.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/root_numpy/root_numpy-4.7.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/root_numpy/root_numpy-4.7.3.ebuild')
-rw-r--r--dev-python/root_numpy/root_numpy-4.7.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/root_numpy/root_numpy-4.7.3.ebuild b/dev-python/root_numpy/root_numpy-4.7.3.ebuild
new file mode 100644
index 000000000000..7561d10b0391
--- /dev/null
+++ b/dev-python/root_numpy/root_numpy-4.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Interface between ROOT and numpy"
+HOMEPAGE="https://github.com/rootpy/root_numpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-physics/root:=[python,${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( tutorial/. )
+ distutils-r1_python_install_all
+}