summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-01 09:25:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-01 09:25:36 +0100
commit9b9c22874161d13ca8d50c952d549f2390f3f179 (patch)
tree008ed76c56f51f6f3c30370c7b6109476f3dd4e4 /dev-python/rich
parent51f111b675c30c05f05128be7836616634098bae (diff)
gentoo auto-resync : 01:06:2023 - 09:25:35
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.4.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index a3f194724103..8369d6e89ed4 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,5 @@
DIST rich-13.3.4.gh.tar.gz 15059899 BLAKE2B f0ca78bf4cdec19136f9372e541ea90713e55acf4dc6f709b8edba9c8dc56da9ac534c6f32b05b634a970e4c02b1f08bfcb5ff949889d6f7bfaa104a1ca6b1cd SHA512 ab3b2ef30ede12f0959671baeff299621303e09750c245b3b3d7b8f1dbd3b7465410400b39668791de57d6027fe24a0a17d5b7284eea162d819c4cb6b9535f81
+DIST rich-13.4.1.gh.tar.gz 15062357 BLAKE2B b5e0067f378910b6a93f0ec40ff47a4ce26298055fba694441962ec2443f9bb76a8ba34ffe43a05abdc077ea8b1d26bbf6294c9d2370baf724045be043c29544 SHA512 655252e9f34da17df6bc7ce74560667f4472da4df6ed699d4302a02301857543ba8756153f48ea8d5a2df5e627ed3c4c8ab732b2b2b27baf66a10c798795a885
EBUILD rich-13.3.4.ebuild 1790 BLAKE2B b448ad02d1e41999de4a1a928a223df97f6c035752b8d8dbbb4931e306816743809fb895c15c6bf2b271bdfbdfdaa01cc7e8500d7e1ccc14f55aa8e7a5657e82 SHA512 d5770a6ef16151d6e937903a12795db31b1f929cf65e5415266408e888bfad950d2882c5460788a0a616cbd5bcda1b064b2c3649c2bdb0f3a3ae4a165eff84d1
+EBUILD rich-13.4.1.ebuild 1874 BLAKE2B c37bb3da347b8b81cc02c5ccbf8bf61ae1a25108f577c2645bfe429bd78d6212bc23c488c538f0a98ba3b165496c5cd05b7acb31363173842e75a498a9b7b3dc SHA512 d3d15f317b83d0a8468767611ebb039edcdf28cf524bc687da5596f66c3f93adb446dfecf57306bb6e2ccf69646c7a926f354fba948953bd756db99a5ec39042
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.4.1.ebuild b/dev-python/rich/rich-13.4.1.ebuild
new file mode 100644
index 000000000000..d8840241d2eb
--- /dev/null
+++ b/dev-python/rich/rich-13.4.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ # version-specific output -- the usual deal
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pypy3.10, to be more precise
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ )
+ ;;
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311_and_above
+ tests/test_pretty.py::test_attrs_broken
+ )
+ ;;
+ esac
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}