summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
commit662f71ae67cd775d7fbb79b5091676c0e07a992b (patch)
tree74c7cb80b79b8886cd7466cf262878d1e8b9d546 /dev-python/rich
parentb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (diff)
gentoo auto-resync : 29:05:2023 - 15:17:30
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.3.4.ebuild11
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 4bc0acbce8de..a3f194724103 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,3 @@
DIST rich-13.3.4.gh.tar.gz 15059899 BLAKE2B f0ca78bf4cdec19136f9372e541ea90713e55acf4dc6f709b8edba9c8dc56da9ac534c6f32b05b634a970e4c02b1f08bfcb5ff949889d6f7bfaa104a1ca6b1cd SHA512 ab3b2ef30ede12f0959671baeff299621303e09750c245b3b3d7b8f1dbd3b7465410400b39668791de57d6027fe24a0a17d5b7284eea162d819c4cb6b9535f81
-EBUILD rich-13.3.4.ebuild 1401 BLAKE2B fda7f17a98414fad1cf7cdc13559931b996fdd876ddf7d16ab9571938ec3425f7c4925934a0b0ebbfdd074796dd5b0eb59f9a2f5f8bf1c2115dc9221b31c8e62 SHA512 71ffa65c5b51bce1b5ff79a3973ffcc2c2944e937823ea8db47ac9b4805ccb5afad40bfab2e6f8c2f7df0b28cfe434362bcdff73b100e12902902cb51e50e534
+EBUILD rich-13.3.4.ebuild 1790 BLAKE2B b448ad02d1e41999de4a1a928a223df97f6c035752b8d8dbbb4931e306816743809fb895c15c6bf2b271bdfbdfdaa01cc7e8500d7e1ccc14f55aa8e7a5657e82 SHA512 d5770a6ef16151d6e937903a12795db31b1f929cf65e5415266408e888bfad950d2882c5460788a0a616cbd5bcda1b064b2c3649c2bdb0f3a3ae4a165eff84d1
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.3.4.ebuild b/dev-python/rich/rich-13.3.4.ebuild
index 574f2f1e1b9d..d5ef23a1e852 100644
--- a/dev-python/rich/rich-13.3.4.ebuild
+++ b/dev-python/rich/rich-13.3.4.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 optfeature
@@ -44,6 +44,15 @@ python_test() {
tests/test_syntax.py::test_python_render_simple_indent_guides
tests/test_syntax.py::test_python_render_line_range_indent_guides
)
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # version-specific output -- the usual deal
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311_and_above
+ tests/test_pretty.py::test_attrs_broken
+ )
+ fi
epytest -p no:pytest-qt
}