summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
commit514c44bb9cc421df9c323acbad430cbb6ee5b89a (patch)
tree22621125c9bc9177d5339f093f57cb928531f33f /dev-python/rich
parent59c2499e0c9720169c9d5a02168c51c807a21467 (diff)
gentoo auto-resync : 15:05:2024 - 00:01:27
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.7.1.ebuild14
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 7fc153d32f38..c7ddfc67346a 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,5 +1,5 @@
DIST rich-13.4.2.gh.tar.gz 15063000 BLAKE2B f65079440bc7d89a3ff03be01fa71e076493ae50f22ae8781be2448a7ff2769c174d6654db3a835d34720c34cd8cbecfdd6b13e3064cf7fdcade71806563309d SHA512 17052a9fb0e1d89b31a00d8a719214719891d048fd805185b2d4258c8766130f44bf2280c9567bc162f3b34d9bf2eb7d747d6a37d910c81cd53d3003b51f70bd
DIST rich-13.7.1.gh.tar.gz 15058064 BLAKE2B 6fad18bf0a4e4f72e530c78db7a498f27dd8c9a7b9b17ca5ef12a94bbe513857f3c42d4903f8ebbfe8907727cddaf290f08862c27efb29db8aaf70c7bcb13ace SHA512 0c69101bc6c2a238a4c516812cda08299115b903b8282ee348b45b212a88fcbfbf69d11a3705a97bdb6192988ee3047804bb5b52b7950d860542cde8ce2d4bd2
EBUILD rich-13.4.2.ebuild 1818 BLAKE2B 100be0b0f6d3f00a867be57b132e05bc831a283373ebb46b92afd2d6cfd6b636b82b2e91ff956787dd18d6d115293f1b65d8ba2f12e6206ebbd2376286942a71 SHA512 162391cb1f36d42388e95f51dea9c0a5f499cb0bba2659444c15aba84971dc8a4324aa4dafa3ca31c8eb4d92e223fd5a4c71b858933f536b99633608c32b3464
-EBUILD rich-13.7.1.ebuild 1392 BLAKE2B abe7bf4c273bb9e9a3e402fcf85387b26ffd193562a123dd1992f0e1eea37fa58d208ba79cf2326d1f8b98c578f56827e31932899a907ebc3a610495de84a19a SHA512 2d5ac8174577cb8697fde8da260631f82e82e381f5353d1005c1690acaa2de00d280be157dec4553f8d9bf922f0f53596f3caefda56225219c3bc9b164c22516
+EBUILD rich-13.7.1.ebuild 1943 BLAKE2B d325ed41f7b05c7d775eafce5706898cd22264ec6496f0aa01e3a2836dd55382befcff991dfc5abc7c3e5eca868a09beb1227cad38278f3ae2109f1aa5db65ff SHA512 f3cdcc65f15f34e92055da324a8c72e105ea8f3160e19d9ebe28c461ccb504253b6a4cdac90557570c54b7c9e832f309b882211a1bf783d3f4aa1bd203a24d7c
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.7.1.ebuild b/dev-python/rich/rich-13.7.1.ebuild
index de4ea8ee4fa4..a5c3df268492 100644
--- a/dev-python/rich/rich-13.7.1.ebuild
+++ b/dev-python/rich/rich-13.7.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 optfeature
@@ -45,6 +45,18 @@ python_test() {
tests/test_inspect.py::test_inspect_integer_with_methods_python310only
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311
+ tests/test_pretty.py::test_pretty_dataclass
+ tests/test_pretty.py::test_reference_cycle_dataclass
+ tests/test_pretty.py::test_max_depth_dataclass
+ tests/test_pretty.py::test_attrs_broken
+ )
+ ;;
esac
local -x COLUMNS=80