summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 17:06:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 17:06:27 +0100
commit4be6deadf3e814bc37585cde9dc08faad2561453 (patch)
tree1e3079a08beb9cfc316ed858851592e9437d5f38 /dev-python/rich
parent1426dfeb15e4d49cb4238c6cf37455a6130cd83f (diff)
gentoo auto-resync : 18:09:2023 - 17:06:27
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.5.3.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index ff4535726365..ca39b10d5a63 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,5 +1,7 @@
DIST rich-13.4.2.gh.tar.gz 15063000 BLAKE2B f65079440bc7d89a3ff03be01fa71e076493ae50f22ae8781be2448a7ff2769c174d6654db3a835d34720c34cd8cbecfdd6b13e3064cf7fdcade71806563309d SHA512 17052a9fb0e1d89b31a00d8a719214719891d048fd805185b2d4258c8766130f44bf2280c9567bc162f3b34d9bf2eb7d747d6a37d910c81cd53d3003b51f70bd
DIST rich-13.5.2.gh.tar.gz 15064941 BLAKE2B 64f7e879588c42db9ac4f2173647143722c1de4865479b975ac5362e8073f60b493193abb0f50fb0d85923fdbe4145b2331fff7564ab78e3b43bc3a1be9d461c SHA512 60dfc66836f277763695611f6a3890da21afbb84bd85f38952efdac78680a8e3faca2e8c0aa937d618f876df1f36d3e67986979aa4fa9b6cb7dfb214f348b8aa
+DIST rich-13.5.3.gh.tar.gz 15065440 BLAKE2B cba268b36499c0f65980ba7b7ce327c53d598b856a39e6c69989b55d488eb0bbe305b6ebf1ca0370251aa8f9ec7dacc6bdee612587a9ace9c66f19d91fdc20b8 SHA512 acae49b796c8ff310b272bca43ce925fe717ddc6252dec20784a4730e63e9c0f81f459ee40b152c001ad0a512e47dddaadbb8fbb949ced262e2d5429b6396344
EBUILD rich-13.4.2.ebuild 1818 BLAKE2B 100be0b0f6d3f00a867be57b132e05bc831a283373ebb46b92afd2d6cfd6b636b82b2e91ff956787dd18d6d115293f1b65d8ba2f12e6206ebbd2376286942a71 SHA512 162391cb1f36d42388e95f51dea9c0a5f499cb0bba2659444c15aba84971dc8a4324aa4dafa3ca31c8eb4d92e223fd5a4c71b858933f536b99633608c32b3464
EBUILD rich-13.5.2.ebuild 1818 BLAKE2B 100be0b0f6d3f00a867be57b132e05bc831a283373ebb46b92afd2d6cfd6b636b82b2e91ff956787dd18d6d115293f1b65d8ba2f12e6206ebbd2376286942a71 SHA512 162391cb1f36d42388e95f51dea9c0a5f499cb0bba2659444c15aba84971dc8a4324aa4dafa3ca31c8eb4d92e223fd5a4c71b858933f536b99633608c32b3464
+EBUILD rich-13.5.3.ebuild 2293 BLAKE2B 0796e63e8486af131e2fc77335b89b8ac63a77e660f6d961ff449ba21ad5f3e8c24378824e28f582bf53ee013515d2479b81527709f7afbed589780eb5a67690 SHA512 60b2132570df7a38977ad8a683971e149b5f2b651044b28042337b5cc8bd6c77dc520bbddad8905a5928adc37ab7e4729bb3cb8dfaaf55461868cd9feb6501ed
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.5.3.ebuild b/dev-python/rich/rich-13.5.3.ebuild
new file mode 100644
index 000000000000..e6eb76070020
--- /dev/null
+++ b/dev-python/rich/rich-13.5.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ tests/test_card.py::test_card_render
+ tests/test_markdown.py::test_markdown_render
+ tests/test_markdown_no_hyperlinks.py::test_markdown_render
+ tests/test_syntax.py::test_python_render
+ tests/test_syntax.py::test_python_render_simple
+ tests/test_syntax.py::test_python_render_simple_passing_lexer_instance
+ tests/test_syntax.py::test_python_render_indent_guides
+ tests/test_syntax.py::test_option_no_wrap
+ tests/test_syntax.py::test_syntax_highlight_ranges
+ )
+ # version-specific output -- the usual deal
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pypy3.10, to be more precise
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ )
+ ;;
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311_and_above
+ tests/test_pretty.py::test_attrs_broken
+ )
+ ;;
+ esac
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}