summaryrefslogtreecommitdiff
path: root/dev-python/rich
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
commit128025db16ea525715d1f5170c635c4f42ce4881 (patch)
tree07a1048840d97aefa9778386f8a8abc27940c708 /dev-python/rich
parent37cf2a8dbadd546a550aac7c8079c3f77427cb63 (diff)
gentoo auto-resync : 13:04:2023 - 11:43:14
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest2
-rw-r--r--dev-python/rich/rich-13.3.4.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 39c38a2040f0..634247b9a0ee 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,5 @@
DIST rich-13.3.3.gh.tar.gz 15060927 BLAKE2B 2d4aaca6dd18b7f3dd6267b3ead09ece8e2edc2ed050c137a93618915f6cd999744957d6925da90446a5b3a46ef871561145d5c2c27ff2722afac24090cf1064 SHA512 049b5145685509f722d744e5b7e2703bf14e5449da02f24e92ac856552bddeef96777760ead4e1e0f6599cc1b13cc424dc558a20c426dcbd7d4230322226832c
+DIST rich-13.3.4.gh.tar.gz 15059899 BLAKE2B f0ca78bf4cdec19136f9372e541ea90713e55acf4dc6f709b8edba9c8dc56da9ac534c6f32b05b634a970e4c02b1f08bfcb5ff949889d6f7bfaa104a1ca6b1cd SHA512 ab3b2ef30ede12f0959671baeff299621303e09750c245b3b3d7b8f1dbd3b7465410400b39668791de57d6027fe24a0a17d5b7284eea162d819c4cb6b9535f81
EBUILD rich-13.3.3.ebuild 1401 BLAKE2B fda7f17a98414fad1cf7cdc13559931b996fdd876ddf7d16ab9571938ec3425f7c4925934a0b0ebbfdd074796dd5b0eb59f9a2f5f8bf1c2115dc9221b31c8e62 SHA512 71ffa65c5b51bce1b5ff79a3973ffcc2c2944e937823ea8db47ac9b4805ccb5afad40bfab2e6f8c2f7df0b28cfe434362bcdff73b100e12902902cb51e50e534
+EBUILD rich-13.3.4.ebuild 1409 BLAKE2B c61286fb5f7abe780dae8b7333935b22323fd0333eb4ee4d4524a859066548f93cd8a767d578c74ff7e533125e426115b56589d4ad0d8c4809b299508a963833 SHA512 d7a7ef1a51747775b944735ab0af8e5c7912fdb92c05dd2d286db52b1a49dd2c0f87e5cd30f7fce2ec597110200faf8dc24b8342ab28d37b08acf721cfa251e6
MISC metadata.xml 387 BLAKE2B 049491e034ba233f33c76dc5e3f1b887ba5d2da9d65b09bda51a7cf4eb30a9c66f3ddf714f52407a73e51da78523084064bccd4fc687e0bc0fc2b32dbb4c513b SHA512 448ce879331748e3166f670981a27ee5c3ef20b51af442ccc684cb6514c0d6a0d4e433a8bc1ddb3bdf68c734bac013c1ba04d38adf90644b062231ab1c1d2c0b
diff --git a/dev-python/rich/rich-13.3.4.ebuild b/dev-python/rich/rich-13.3.4.ebuild
new file mode 100644
index 000000000000..dcd6ae234066
--- /dev/null
+++ b/dev-python/rich/rich-13.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ <dev-python/markdown-it-py-3[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ tests/test_inspect.py::test_inspect_integer_with_methods_python38_and_python39
+ # pygments?
+ tests/test_syntax.py::test_python_render_simple_indent_guides
+ tests/test_syntax.py::test_python_render_line_range_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}