summaryrefslogtreecommitdiff
path: root/dev-python/rfc3987
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-python/rfc3987
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/Manifest2
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.8.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rfc3987/Manifest b/dev-python/rfc3987/Manifest
index 37728fc83b9f..5642098c9a15 100644
--- a/dev-python/rfc3987/Manifest
+++ b/dev-python/rfc3987/Manifest
@@ -1,3 +1,5 @@
DIST rfc3987-1.3.7.tar.gz 20701 BLAKE2B 234f3dc60d83e5615ae9fbbc14d063f9a993a532f5e7042144a8f5e995d44a27d88c284f7e12ff1f3f92d2440333438b3e1a0804ab43ca229305ce20ec4cb4f2 SHA512 c5fa8eb36358f7f42d12adc305031bfff7bd77e83316ad4458ed07acc6094c7d9109b95848b9296dcbc6677ce34aa59b1be8fd57dfcdc6be47eb92aeda51c518
+DIST rfc3987-1.3.8.tar.gz 20700 BLAKE2B 0662a5f376680a18eb58c76b5d1d4df653f62df7175f8c3f828cf8a410f900ba8feb81faf4ce40fabeecb74047e6b1542e170fba946d3189b18c553f16eda1e4 SHA512 0e81b8dbc8c410f08b1efa7ee1c90174ed6e70bf7622d3748f598d383583b439908e1b5da1e1a1eb22af4f214ae08680a29f00b253f37808034bae8a1808c32c
EBUILD rfc3987-1.3.7.ebuild 789 BLAKE2B 9605f6c0d582efab70d22495d49c5a44b2ed84491020a1a89b552717961af9fd211c95f686626e0cf2f2b92628b4c35f14333d316f56048d7d6bf22e9ba9b819 SHA512 2577bf9cdce3a2538e4fbf73007f7c5d04f53e9c3f97e4a8c97083e8349fb906dd411f2880f5e1402833bface2043dc97c6d88caf8a90f53e52e3f087eef13fe
+EBUILD rfc3987-1.3.8.ebuild 796 BLAKE2B 150d4813d5bdce12e11a2bf2aeb54f241f3305e8f102e966eeb598794dc009b4a481958ca8d5372c83c15d2665d829fa300de3b056fd833398dfe506861a2495 SHA512 a7e462503168f667d34d55535e0ed6a23153b72882b042cace327b7e9729a6ab900f9507aba8611eec961a540970046ef950b6cd4a281b21560ca0e87653d05d
MISC metadata.xml 571 BLAKE2B c366d3c4f3cb52d43bf469e77610cb6cfdd57b82ef0f46e8f1dbc739637bae6805edf5086deb4779738be7d29c4c73f7d658050112e9f5be62debc22a735f61c SHA512 2ced33f8245fc320ca1795072d9e63b5cc910b90f368306112316dcb444ee24f292e39ff76dfb027edcaf2c7a6dbfa636414ab8f9cfe777b0a2aeed17143e8c0
diff --git a/dev-python/rfc3987/rfc3987-1.3.8.ebuild b/dev-python/rfc3987/rfc3987-1.3.8.ebuild
new file mode 100644
index 000000000000..7e5f142779dc
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.org/project/rfc3987/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep \
+ 'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}