summaryrefslogtreecommitdiff
path: root/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 05:34:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 05:34:35 +0000
commite644f875e1d27155e8829b8f7385a8b2d790bcce (patch)
tree34f399ec8067712dc6b5416ac39685d1999649c7 /dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
parent0771aa27d30f102abe2c5733a138ffe570da4d15 (diff)
gentoo auto-resync : 11:02:2024 - 05:34:35
Diffstat (limited to 'dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild')
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild b/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
deleted file mode 100644
index e8a27e88d645..000000000000
--- a/dev-python/rfc3987/rfc3987-1.3.8-r2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
-HOMEPAGE="
- https://github.com/dgerber/rfc3987/
- https://pypi.org/project/rfc3987/
-"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-
-# dev-python/regex doesn't support pypy. The package falls back to re and has most
-# functionality without it.
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/regex[${PYTHON_USEDEP}]
- ' 'python*')
-"
-BDEPEND="
- ${RDEPEND}
-"
-
-python_test() {
- "${EPYTHON}" -m doctest -v "${S}/${PN}.py" || die
-}