summaryrefslogtreecommitdiff
path: root/dev-python/responses
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
commit3a5772102e4f2b6f9cc46f461c90970060ae0c5e (patch)
treed5aebb2508413a75408fd60bd4cb2c886b78ba89 /dev-python/responses
parentf7379fa6ffb6e47eabc62d0d832a5bcad1db9591 (diff)
gentoo auto-resync : 14:02:2024 - 11:36:23
Diffstat (limited to 'dev-python/responses')
-rw-r--r--dev-python/responses/Manifest2
-rw-r--r--dev-python/responses/responses-0.25.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/responses/Manifest b/dev-python/responses/Manifest
index d3e828e983dc..701cc14f5f08 100644
--- a/dev-python/responses/Manifest
+++ b/dev-python/responses/Manifest
@@ -1,3 +1,5 @@
DIST responses-0.24.1.tar.gz 77530 BLAKE2B 6f4482a0b7f7388506782286e35e716b4fcb746f6d562cba3e5b095163e380e0921f71f808c4729c2c6fb03c3efa1005ae6dbab9d3b61275af720b215b4e4181 SHA512 fd97f56055da4e31fc9866e4fdb7d68b2273cac25c6d882811268daf5f474d21897454b790122ed4c12e18032b9ae2c032b958402c6840b46ec38fdd7306033f
+DIST responses-0.25.0.tar.gz 77681 BLAKE2B 0437c343feecb071f544d8f6ce1ad15c4d6e2f00c0fff0404dff9160c962a5de46d0b2c882e8d044b6e09c441a534e7bd8772f826a45c9a9b79e34daf0610546 SHA512 6aed8ce17f55e8c1a7438b3e1aa7e7e59322120f3580fede93d61224ea9f1e1f05382cdf82c11cbef29447b6591d7d6e25d156c087025b93d6e5a3e2da82d90d
EBUILD responses-0.24.1.ebuild 1166 BLAKE2B 54d8f17603906527ecc0b084a2312f26d817ea10ae19e3df6196962479154a7cdcb7bda637bd4543f6ac541a3afc8b80fbec482130441ba8cf3d6de93c0deb9e SHA512 6c640fb9cc53b1bc59171ead81e33dea009f1cf5d36c596ac685c622115dd1adc7e8a5ea9a5c0f1248596262a042e5595617cfc8a4f3e2fdf390f2ee90717e70
+EBUILD responses-0.25.0.ebuild 1174 BLAKE2B 844ceab8e027093331b800ec14d1e72041b9d982ff20940cf24e4ecaa0a523350e6b3625ffb94f09bfdf6020ad641d26a3ff90118227087d616d8c8af916cb84 SHA512 b818eb31dbe83897cc580ee4cbd87668558fbc7b04b2f5ff2bf9a86b8b4300f1a7ad4e2feed59dd6a9b4af25d45a6a5b1b64e8b1a6bdfa831c9ef1990e683f06
MISC metadata.xml 463 BLAKE2B 64d3c7be57863ae6088ce746fbfcc68a8eefc37c6d8fbe1bc6866d4c24ad18e75215158d89217d13f0e5b9db2e82d1aab86fa2ff664098239440bfd3fa3e7cd1 SHA512 546de31e1cde62b866673aedb4d3c1278213b36cc75fe86a8e759eaf16471cdefe91d6b0005b4ec4caf4316f8449717d672ede4181f1c1912f5647d50557eca9
diff --git a/dev-python/responses/responses-0.25.0.ebuild b/dev-python/responses/responses-0.25.0.ebuild
new file mode 100644
index 000000000000..f474e5d90dc1
--- /dev/null
+++ b/dev-python/responses/responses-0.25.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Utility for mocking out the Python Requests library"
+HOMEPAGE="
+ https://pypi.org/project/responses/
+ https://github.com/getsentry/responses/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# tomli backend is optional now, with pyyaml being the new default.
+# However, keeping it unconditional here for backwards compatibility.
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.30.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}