summaryrefslogtreecommitdiff
path: root/dev-python/resolvelib/resolvelib-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
commit34fb4543abc1dae6f74171ad8dc80fa64636a941 (patch)
tree5923cd4dc2a560dba9b618db67713ae10cf92f75 /dev-python/resolvelib/resolvelib-0.9.0.ebuild
parent1536d928ae095e00db8775fecca580c10adc0af8 (diff)
gentoo auto-resync : 17:11:2022 - 12:56:42
Diffstat (limited to 'dev-python/resolvelib/resolvelib-0.9.0.ebuild')
-rw-r--r--dev-python/resolvelib/resolvelib-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/resolvelib/resolvelib-0.9.0.ebuild b/dev-python/resolvelib/resolvelib-0.9.0.ebuild
new file mode 100644
index 000000000000..ccfd21367fce
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve abstract dependencies into concrete ones"
+HOMEPAGE="
+ https://github.com/sarugaku/resolvelib/
+ https://pypi.org/project/resolvelib/
+
+"
+SRC_URI="
+ https://github.com/sarugaku/resolvelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/commentjson[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest