summaryrefslogtreecommitdiff
path: root/dev-python/requestsexceptions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/requestsexceptions
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/requestsexceptions')
-rw-r--r--dev-python/requestsexceptions/Manifest4
-rw-r--r--dev-python/requestsexceptions/metadata.xml15
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild21
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/Manifest b/dev-python/requestsexceptions/Manifest
new file mode 100644
index 000000000000..b86e2f1923ac
--- /dev/null
+++ b/dev-python/requestsexceptions/Manifest
@@ -0,0 +1,4 @@
+DIST requestsexceptions-1.1.3.tar.gz 6606 SHA256 d678b872f51f76d875e00e6667f4ddbf013b3a99490ae5fe07cf3e4f846e283e SHA512 33a848b04db500b3481b7df2553e244e1967e5124de1606f73fb38f0b2681253ca2bd921386ce50f1144a8dc8d6f8e07be058a3d9f13c7831f77cade0a42fd38 WHIRLPOOL b806c364b25b05a7659062a92cb1cf5131ebeee1fff2539d1e898d4294595eb4c0d91736a88e05c99b49b0d4d3f984189574055b6aae9e95b302cd9c002d3ba5
+EBUILD requestsexceptions-1.1.3.ebuild 571 SHA256 0038772b3136061d5a1dd15e4fa6df2f5e9897f2a560fb013cf1a1aff88634be SHA512 c64495bf3a1f3f344b5d436e18b65449177db3ed08f417ac5328e4018c7b57474d981783e0ce53c509999cb98b4e0cef3607ee94f46b1aeed7f70308e2e1d164 WHIRLPOOL 64eab323755591fee16f89f6d164eb05ff5de3e354b9fb4c1af32916bd9288d2a6db13f3c65f03399d90b67777153fc9a6330452cd3656cd05d5fff06c0936bd
+MISC ChangeLog 653 SHA256 bc6ba5858f522c935bf664c9ea24cdd63b006dcb4a4da8b59db22596f216ce77 SHA512 74d90c93091bc84940858c3b711d1126fc3cd229c24a3dc6bf508dfd35278e310b16270f35b402e4719fc39924146be6d43eac6d6cdcede307fa79b4e788bd54 WHIRLPOOL 5aee639a9845d043f5bb8873fec86935a05e8fe604fe4b3102a835c872d2dfbbc768ad8d7cac5f031f171c6b6209fb3c6611fd4a3c033ef9b6921cf9c06384a9
+MISC metadata.xml 846 SHA256 59c4a2317720cd07c0e9717fdfd029c39c88117802118eb14e4a3eaf033f8439 SHA512 d2ee4202dd7751d3caddc2c90b3d3c309b29ba1c7caf3427853944a7a5bea1d26a171fa59fff4f80e07235b3853990faa9dbad24ac0075fb813c4b91ddc4ab08 WHIRLPOOL 0d5767987ff047d75af3e303053e40339d63d0a54f46ab1213bc84afe63f8715d77ab4ea4834c4931adb3e2ea9a713c236b95d24350d455812647e5201dc2dd5
diff --git a/dev-python/requestsexceptions/metadata.xml b/dev-python/requestsexceptions/metadata.xml
new file mode 100644
index 000000000000..26800899dbff
--- /dev/null
+++ b/dev-python/requestsexceptions/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ The python requests library bundles the urllib3 library, however, some software distributions modify requests to remove the bundled library. This makes some operations, such as supressing the "insecure platform warning" messages that urllib emits difficult. This is a simple library to find the correct path to exceptions in the requests library regardless of whether they are bundled.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">openstack-infra/requestsexceptions</remote-id>
+ <remote-id type="pypi">requestsexceptions</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
new file mode 100644
index 000000000000..0260b7f92a9d
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library."
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"