summaryrefslogtreecommitdiff
path: root/dev-python/requests_pkcs12
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/requests_pkcs12
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/requests_pkcs12')
-rw-r--r--dev-python/requests_pkcs12/Manifest3
-rw-r--r--dev-python/requests_pkcs12/metadata.xml15
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/Manifest b/dev-python/requests_pkcs12/Manifest
new file mode 100644
index 000000000000..a645d494c0cc
--- /dev/null
+++ b/dev-python/requests_pkcs12/Manifest
@@ -0,0 +1,3 @@
+DIST requests_pkcs12-1.4.tar.gz 3884 BLAKE2B ebeb89349163d4f9995c00dfe3d725036a76660870d36203f47029f225698fe7a15993a9dd756e0b6b33011726ad26323962609bb94f223f4478096658f20a3c SHA512 f77703b7b0ba1f13aa095fcf4955f119c34a20e0601e0d6888a29932d8d4289548cf2b7b0e065abfea2ebcda542d48a4d9a3ded32974c1d24bdae223893f0241
+EBUILD requests_pkcs12-1.4.ebuild 575 BLAKE2B f42d65935645720be3523ac37590224acbaebe5411857a5f1517d32be3a2492e6a75a79f1e54ef058ab82d9e00c9c503c607e1d668c2622ce9ec179b01b9a567 SHA512 52cc2fc2d9809dc712f2f56f32de93fb794c7fcbf40ed3ae233eb8382af1bddef3eb51787fc784e0cb6991cf7e52b3f37e60b72c712627ec5789f79081f017ea
+MISC metadata.xml 555 BLAKE2B d70dda6dc42c1a4da489771576e149a106fd0dae72477045e98a57c2fcd04552057d526b52da2c1b1ced97a118a6c0d914100ebe0e2996a12cfc55c9f66da128 SHA512 3ae1a29b15280f429202f4b031ffde905a26056964ba53610ae29f961d3f7c2562b8a5d27d701b3c1a72204464cf5c4ede628339ce3e6874aed62f127523f32b
diff --git a/dev-python/requests_pkcs12/metadata.xml b/dev-python/requests_pkcs12/metadata.xml
new file mode 100644
index 000000000000..0a878536db01
--- /dev/null
+++ b/dev-python/requests_pkcs12/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Adds PKCS#12 support to the Python requests library in a clean way, without monkey patching or temporary files.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">m-click/requests_pkcs12</remote-id>
+ <remote-id type="pypi">requests-pkcs12</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild
new file mode 100644
index 000000000000..717b7c6e3fa5
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"