summaryrefslogtreecommitdiff
path: root/dev-python/requests/files/requests-2.22.0-pytest-4.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/requests/files/requests-2.22.0-pytest-4.patch
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/requests/files/requests-2.22.0-pytest-4.patch')
-rw-r--r--dev-python/requests/files/requests-2.22.0-pytest-4.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/requests/files/requests-2.22.0-pytest-4.patch b/dev-python/requests/files/requests-2.22.0-pytest-4.patch
new file mode 100644
index 000000000000..5b8ec34912d9
--- /dev/null
+++ b/dev-python/requests/files/requests-2.22.0-pytest-4.patch
@@ -0,0 +1,27 @@
+From dc75b3ca0b4c95648eb07b92cb414394d99c13a0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Mon, 8 Apr 2019 18:04:22 +0200
+Subject: [PATCH] Support pytest 4
+
+Fixes https://github.com/kennethreitz/requests/issues/5048
+
+See https://docs.pytest.org/en/latest/deprecations.html#marks-in-pytest-mark-parametrize
+---
+ setup.py | 2 +-
+ tests/test_utils.py | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_utils.py b/tests/test_utils.py
+index 59b0b0efa..62c51494d 100644
+--- a/tests/test_utils.py
++++ b/tests/test_utils.py
+@@ -33,7 +33,8 @@ class TestSuperLen:
+ 'stream, value', (
+ (StringIO.StringIO, 'Test'),
+ (BytesIO, b'Test'),
+- pytest.mark.skipif('cStringIO is None')((cStringIO, 'Test')),
++ pytest.param(cStringIO, 'Test',
++ marks=pytest.mark.skipif('cStringIO is None')),
+ ))
+ def test_io_streams(self, stream, value):
+ """Ensures that we properly deal with different kinds of IO streams."""