summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 22:17:13 +0100
commitec321939a77843497c860196ea06d7776d94b755 (patch)
tree426c3b59f57bfb684b461e65c4416048b369b4ce /dev-python/requests-cache
parent2982504d287f7f91eade76902f11e691f8181071 (diff)
gentoo auto-resync : 02:09:2022 - 22:17:13
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest2
-rw-r--r--dev-python/requests-cache/requests-cache-0.9.6.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index f5988bfff85a..0b2db1dfd643 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,3 +1,5 @@
DIST requests-cache-0.9.5.gh.tar.gz 1542034 BLAKE2B 01996e7536ce967dee2b909091d1eb08501b3882b6171a5460b2196666eed848dec89a85ef8ea0c892b2fd153f90107948239de04b973e7766d3acfad7b10059 SHA512 de1481ff609f3ff36ed662d986fb86a500a8d26755832478a9a4396f2c71934b5f65540137b92365eb36f66087b3fbc1cd72c63d37546d09c86bbee7340fd8eb
+DIST requests-cache-0.9.6.gh.tar.gz 1514642 BLAKE2B 1b098b14a677976b1e767e63b8b5f6c1a3e89b5023b6150f0d186aefe0dad14ad9999e1b036b436759ec4b27b6663159d2a8538dbf99a9017c18a34f0c117d94 SHA512 88e4745bed278224ccd1eb815a4f9da84051bab79c43122fa97899c3a8ad87ad7bfd929f87680eb6f73b1ff14267d2519afd9ef8815f10597769cab8ada7f8b5
EBUILD requests-cache-0.9.5.ebuild 1800 BLAKE2B 94b814c239d343e3515c79c34b353a0920fba71b0139cac1f7d3332f891ac6d8cbfff2c68aaed8b47419606a4ed68b3950f04fe74ad83760eb17acf242983403 SHA512 c5483081f64e6a05343e9c57f32b715401d323558150bbb34e120fc351f3284a1439a50637dcf8045fa690b052597c43a60645972703241ff437f9e08f4e83da
+EBUILD requests-cache-0.9.6.ebuild 1796 BLAKE2B 7c0b3557a722924b9d4cab7a0e05799190db67b2f19e422a193dd31dd7fab84b2be22efeb830c310baff5f17f53c6413afd3d6f01318afcbc3172cfd61403317 SHA512 d736bc35799a00cab9aac619234f5f077f9de6a88ed6ac977adad3304ea9eb6ad4a2dd5841db10b985c0a57b7bf43a67fbedccdd908dfedfc9eb33207170f49f
MISC metadata.xml 541 BLAKE2B a8fd81921a36e2fe5bdec38cc1039b9e91971c992a59cbe2dc4826977f753bd6cd2533f65b5f1a076308a898972fe70e85a2c8cf480259e9801f51b10c4de8a4 SHA512 64f29b67eaf3ce892a9f918abd7eaf8f020323e9e0d986b424cffc83e3ac1ba5cb14b534f0a0ec73a8e81694ca4e0e7f98ef02968ac5b43dab104b2b12e8e0f2
diff --git a/dev-python/requests-cache/requests-cache-0.9.6.ebuild b/dev-python/requests-cache/requests-cache-0.9.6.ebuild
new file mode 100644
index 000000000000..5f7e2eced4f4
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.9.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/requests-cache/requests-cache/
+"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cattrs[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ )
+ local EPYTEST_DESELECT=(
+ # Requires Internet access
+ tests/integration/test_compat.py::test_version_upgrade
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "redis backend" "dev-python/redis-py"
+ optfeature "MongoDB backend" "dev-python/pymongo"
+
+ optfeature "JSON serialization" "dev-python/ujson"
+ optfeature "YAML serialization" "dev-python/pyyaml"
+ optfeature "signing serialized data" "dev-python/itsdangerous"
+}