summaryrefslogtreecommitdiff
path: root/dev-python/regex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /dev-python/regex
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'dev-python/regex')
-rw-r--r--dev-python/regex/Manifest2
-rw-r--r--dev-python/regex/regex-2016.01.10.ebuild46
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/regex/Manifest b/dev-python/regex/Manifest
index 7f60ab34dac0..c7f978096d5f 100644
--- a/dev-python/regex/Manifest
+++ b/dev-python/regex/Manifest
@@ -1,5 +1,3 @@
-DIST regex-2016.01.10.tar.gz 574017 BLAKE2B a9411450fe2864c8b088aa97b8591df64b5149c54984c8c014f498a209dcf665e65df29088495fdca2b3dc7aad72bf3064611b6a061d6bd89ddc1624679c5a13 SHA512 4f4700ca746763f857449003d32d56b5aa8069e3b71b160e719633b0cf00f80efc0766d8e1e193977278f91bd3e73c87aab31bee23aec77557ac9b3652ff6a2f
DIST regex-2017.04.05.tar.gz 601638 BLAKE2B a7c094887b602f24e68c51c92098604c462d506b13f064beaebdec081fd28d39dac9934fface0de0444dc6145af5f4c0e8ab2cd3b65ecfc2c1ca522682b3bf95 SHA512 4c3e440e11f57e2323892e10fbed7f2c89b35771fdc970164ba69bb154dde535f6edb51a0997c924eb776c61e5efd1d04001abd343110518a89b5b7bf148ae49
-EBUILD regex-2016.01.10.ebuild 1154 BLAKE2B 4f4270fd08b90a31de9186fcb448f822db9ff5635f88b514e3368bce6e4f81c06254137e30ea512c9db6eec580fe26bc4a9b18dd79b9853d845d84a52798c107 SHA512 aebd29d84c8a237ef3d544ef777be950232aedcb9b9a6c48482eb03cb4c991e56dc911f75c1da1849cc42239eea06f2e968573aaf03f405f60a50daea11e0d39
EBUILD regex-2017.04.05.ebuild 1197 BLAKE2B 4cfb5d4e54f6d16805a3ba8faaa3b7dbfce58546bfbbf641bdcdea9285c97fdb11d190f389ad5691e994bcc4c84fe044787ebab89f021938b9d2370ac08ab2dd SHA512 c7839519a38b08bdfe53502befacda7c352c5c9b9bf032145b65d3c922d9d390d0c1b6afc7795068f12fb74b8ee167c40e819e930f990b11a310de1da76269ee
MISC metadata.xml 384 BLAKE2B 4928f66b54b5e4de6a8b913207ec6e46c124e55510eac304a7fd46c6ca63cce60704757e9289bf35d2d58e9ddcd4aa98d751a079c79f09dda9206553096e0561 SHA512 3db0a8abe7036cd9d0fd8b1450598436dbb30581806380ad51c3d0f49d129325aba1bad9700d14adffc7cfd199c4ec3377e6eb0225244bfc82368bbb50548e07
diff --git a/dev-python/regex/regex-2016.01.10.ebuild b/dev-python/regex/regex-2016.01.10.ebuild
deleted file mode 100644
index e682641366e1..000000000000
--- a/dev-python/regex/regex-2016.01.10.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Alternative regular expression module to replace re"
-HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="doc"
-
-DOCS=( README docs/UnicodeProperties.txt )
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- local msg="tests failed under ${EPYTHON}"
- # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
- einfo "There is one trivial fail of test test_empty_array under pypy"
-
- if python_is_python3; then
- "${PYTHON}" Python3/test_regex.py || die $msg
- else
- "${PYTHON}" Python2/test_regex.py || die $msg
- fi
-}
-
-python_install_all() {
- local DOCS="${DOCS} docs/UnicodeProperties.txt"
- use doc && local HTML_DOCS=( docs/Features.html )
-
- distutils-r1_python_install_all
-}