summaryrefslogtreecommitdiff
path: root/dev-python/regex/regex-2017.04.05.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/regex/regex-2017.04.05.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/regex/regex-2017.04.05.ebuild')
-rw-r--r--dev-python/regex/regex-2017.04.05.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/regex/regex-2017.04.05.ebuild b/dev-python/regex/regex-2017.04.05.ebuild
deleted file mode 100644
index bde151338bb2..000000000000
--- a/dev-python/regex/regex-2017.04.05.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Alternative regular expression module to replace re"
-HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd"
-IUSE="doc"
-
-DOCS=( README docs/UnicodeProperties.txt )
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS=${CFLAGS}
- append-cflags -fno-strict-aliasing
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- local msg="tests failed under ${EPYTHON}"
- # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
- einfo "There is one trivial fail of test test_empty_array under pypy"
-
- if python_is_python3; then
- "${PYTHON}" Python3/test_regex.py || die $msg
- else
- "${PYTHON}" Python2/test_regex.py || die $msg
- fi
-}
-
-python_install_all() {
- local DOCS="${DOCS} docs/UnicodeProperties.txt"
- use doc && local HTML_DOCS=( docs/Features.html )
-
- distutils-r1_python_install_all
-}