summaryrefslogtreecommitdiff
path: root/dev-python/regendoc/regendoc-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/regendoc/regendoc-0.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/regendoc/regendoc-0.5.ebuild')
-rw-r--r--dev-python/regendoc/regendoc-0.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/regendoc/regendoc-0.5.ebuild b/dev-python/regendoc/regendoc-0.5.ebuild
new file mode 100644
index 000000000000..450ca696df50
--- /dev/null
+++ b/dev-python/regendoc/regendoc-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="RegenDoc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Check/update simple file/shell examples in documentation"
+HOMEPAGE="https://pypi.org/project/RegenDoc/
+ https://bitbucket.org/pytest-dev/regendoc/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"