summaryrefslogtreecommitdiff
path: root/dev-python/reflink/reflink-0.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 17:40:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 17:40:43 +0000
commit24ee8c58752f0dc4376961a28f7364e6d7c7a7aa (patch)
tree0a71618e774dce4efc0ddc7808557a03925de8d9 /dev-python/reflink/reflink-0.2.2.ebuild
parenta625efe29cec7f7c437cf33a956ea99eed1e4bd9 (diff)
gentoo auto-resync : 24:02:2024 - 17:40:43
Diffstat (limited to 'dev-python/reflink/reflink-0.2.2.ebuild')
-rw-r--r--dev-python/reflink/reflink-0.2.2.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/reflink/reflink-0.2.2.ebuild b/dev-python/reflink/reflink-0.2.2.ebuild
index 83e0653fe4a1..df133fc37b1f 100644
--- a/dev-python/reflink/reflink-0.2.2.ebuild
+++ b/dev-python/reflink/reflink-0.2.2.ebuild
@@ -18,6 +18,9 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
+# The test suite mounts a btrfs volume on a loopback device.
+PROPERTIES="test_privileged"
+RESTRICT="test"
RDEPEND="
$(python_gen_cond_dep '
@@ -41,15 +44,13 @@ src_prepare() {
}
src_test() {
- rm -rf reflink || die
-
- if [[ ${EUID} != 0 ]]; then
- ewarn "Tests require root permissions (FEATURES=-userpriv)"
- elif [[ ! -c /dev/loop-control ]]; then
+ if [[ ! -c /dev/loop-control ]]; then
die "Tests require /dev/loop-control"
- else
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- addwrite /dev
- distutils-r1_src_test
fi
+
+ rm -rf reflink || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ addwrite /dev
+ distutils-r1_src_test
}