summaryrefslogtreecommitdiff
path: root/dev-python/redis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
commit5c0cc325922d72d6e614def2a9b36ee95a46d2c1 (patch)
tree2734b6847fc660dd18cfcf5f839e14aad0188ad0 /dev-python/redis
parent35a2663a10c1124ae2951397ed2a4435dc5808e5 (diff)
gentoo auto-resync : 28:10:2023 - 22:35:05
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/Manifest2
-rw-r--r--dev-python/redis/redis-5.0.0.ebuild105
2 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index 0e2f78f1a2e3..23b9bee6ae55 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,5 +1,3 @@
-DIST redis-py-5.0.0.gh.tar.gz 4767898 BLAKE2B 0dc1fcafe7ad82c00bf634e19b5afb7201f39dfd26dfcce398fbc40cff79fe03d3e2ecc2acccebf1405700fb72fc5894ce1b8438b55e6c10d52ec08124da50cb SHA512 24133be64b73a58edd7b0361a8b168b67f0e783576aaf0007f4b4b8d6032a227d6ebc7319c89fc323fc72ef1063e4a899d9a8be9eaa833d347345a59a65fff31
DIST redis-py-5.0.1.gh.tar.gz 4769633 BLAKE2B 3b572ef41abfdb0cf0ba957c93a23aacbe931e50ebe11e50a62dffe6aaaf57926224f7a497727e1e233b443c6be053f786dadac64f16a5170748e6afd9604d01 SHA512 05c32d6961326ff39312f5513136e72be3a42819b0c4bf646f3bac14e66a8a87a191697a89c2cbc22a83398896e25adc5fbd34f12e67719f0a0af927bf423130
-EBUILD redis-5.0.0.ebuild 2700 BLAKE2B fdf694b2598f58bca6a5b595cb2befd87a22f5b39eafbaa240ce4ec4acb42e0550b51bff01513418747262ca8c97089b44668dd6147cf2c5512a0cd74614249b SHA512 d65cd1b666966deb2ffdeedb2f8cd8c1b9ebbfca403108ca7236ce0cd05a7ef0c4e07718fea5e254433ee8b676f876c1eac237991eb592a3de6d5609caaa26d7
EBUILD redis-5.0.1.ebuild 2700 BLAKE2B fdf694b2598f58bca6a5b595cb2befd87a22f5b39eafbaa240ce4ec4acb42e0550b51bff01513418747262ca8c97089b44668dd6147cf2c5512a0cd74614249b SHA512 d65cd1b666966deb2ffdeedb2f8cd8c1b9ebbfca403108ca7236ce0cd05a7ef0c4e07718fea5e254433ee8b676f876c1eac237991eb592a3de6d5609caaa26d7
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis/redis-5.0.0.ebuild b/dev-python/redis/redis-5.0.0.ebuild
deleted file mode 100644
index 773b415b4d2f..000000000000
--- a/dev-python/redis/redis-5.0.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=redis-py-${PV}
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="
- https://github.com/redis/redis-py/
- https://pypi.org/project/redis/
-"
-SRC_URI="
- https://github.com/redis/redis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
- ' 3.{9..10})
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
- # require extra redis modules that apparently aren't packaged
- # on Gentoo
- tests/test_bloom.py
- tests/test_graph.py
- tests/test_json.py
- tests/test_timeseries.py
- # apparently available only in "Redis Stack 7.2 RC3 or later"
- tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
- tests/test_commands.py::TestRedisCommands::test_tfunction_list
- tests/test_commands.py::TestRedisCommands::test_tfcall
- # TODO
- tests/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
- )
-
- case ${EPYTHON} in
- python3.12)
- EPYTEST_DESELECT+=(
- tests/test_asyncio/test_connect.py
- tests/test_asyncio/test_cwe_404.py
- )
- ;;
- esac
-
- # TODO: try to run more servers?
- epytest -m "not redismod and not onlycluster and not replica and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- if has_version ">=dev-db/redis-7"; then
- local extra_conf="
- enable-debug-command yes
- enable-module-command yes
- "
- fi
-
- # Spawn Redis itself for testing purposes
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1 ::1
- ${extra_conf}
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}