summaryrefslogtreecommitdiff
path: root/dev-python/redis-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
commit7051f2e58b6bbc371b2c94cead2715bf06310adb (patch)
treed8eb7cbcdfa3883fcdb1cb004774e17be52600b0 /dev-python/redis-py
parent3b4acc0bc0b77136b371d8a3119066f80f221efe (diff)
gentoo auto-resync : 11:01:2023 - 23:45:17
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest2
-rw-r--r--dev-python/redis-py/redis-py-4.4.2.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index 3dff94933650..75c6504b0ae8 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -1,5 +1,7 @@
DIST redis-py-4.4.0.gh.tar.gz 4637656 BLAKE2B 40b0909c27cefb399353cc2d1d82d7ad3d64e4b3e5ae001ffef9c198d0e65d906f5772a0ac33b599c7fb6ffc5dfad461bb4b9042c5c4fb23dfbfceb0a7facbc0 SHA512 8992f160de7817c48893f3a8588d5c0398dcfb91830a61b4218206adc88185acb102b072507d3064b4a7aade5c957267e5d0e6912510bb106eea834cf9250fab
DIST redis-py-4.4.1.gh.tar.gz 4733306 BLAKE2B b04a5925f87d8c1dbb06b30382f739d6bc39456b6b49be34701afcc1fecfca4783e60a451ddccdaff31f28c38b626e19607a57ebd600f7e28c63a4b62894f397 SHA512 0cec4b518bb56acee6a24ca62e7fdce054b4be764fcfaa860257d8de9f306d9d0f15a662354d7414a4a552475e2b49d97d97de05059310eead068a6269bc3038
+DIST redis-py-4.4.2.gh.tar.gz 4734100 BLAKE2B 8e23c9b81a19cbbead7d6dab682fc4efc75f0c29adb4df6b9bf17f6842b2823249036c67c133039a850504870a0f884275eb65f4e517f84211b51767d7a2ae15 SHA512 3303e87ccc9d4ea3afbb93bcc5e4dcc5bbb3a406878b07c5b8755f28f87cb7a0f9a0db989ec294c2cf42c4ec62f546b5d919a3cb3f11b4ba030e41d13ed2cfc8
EBUILD redis-py-4.4.0.ebuild 1741 BLAKE2B ff2e4b6cec372b495f8e9151dd64d1d53ce01e8e67546ee4852c24960987c14f5aac49c938cd8addfc4b920008dce12ba8976f7c72b3883af41bc7e8f5dbb472 SHA512 40fc7d02058618f1c4e45a0879be7f2f74795fec909af1c6707d51ca1d53a76b949b5d4799d331473e30de56f37f99c67f33831a5aa2045797f3ba4ae0373a5f
EBUILD redis-py-4.4.1.ebuild 1748 BLAKE2B 181171f8769e70a8278344b0ca14119f35742b469179dd9b847c3d3cb6854adb76bb15c5d9db0f7ec983483cd7c3cbd58d97414c520bfd1aaa21aa651a06b99a SHA512 5ca7c4dd207a04a3c4f7eb4da41ca839b66787868fc505ba8a5ebda2e4b370113df2cbfe6df3908a2f4267640c87a3a318bffeb0d30b8f50b15c2578d10bdf19
+EBUILD redis-py-4.4.2.ebuild 1748 BLAKE2B 181171f8769e70a8278344b0ca14119f35742b469179dd9b847c3d3cb6854adb76bb15c5d9db0f7ec983483cd7c3cbd58d97414c520bfd1aaa21aa651a06b99a SHA512 5ca7c4dd207a04a3c4f7eb4da41ca839b66787868fc505ba8a5ebda2e4b370113df2cbfe6df3908a2f4267640c87a3a318bffeb0d30b8f50b15c2578d10bdf19
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis-py/redis-py-4.4.2.ebuild b/dev-python/redis-py/redis-py-4.4.2.ebuild
new file mode 100644
index 000000000000..cd0794a5536c
--- /dev/null
+++ b/dev-python/redis-py/redis-py-4.4.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ # TODO
+ tests/test_commands.py::TestRedisCommands::test_acl_list
+ # redis-7 different return
+ tests/test_commands.py::TestRedisCommands::test_xautoclaim
+ )
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ if has_version ">=dev-db/redis-7"; then
+ local extra_conf="
+ enable-debug-command yes
+ enable-module-command yes
+ "
+ fi
+
+ # Spawn Redis itself for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ ${extra_conf}
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}