summaryrefslogtreecommitdiff
path: root/dev-python/recommonmark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/recommonmark
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/recommonmark')
-rw-r--r--dev-python/recommonmark/Manifest3
-rw-r--r--dev-python/recommonmark/metadata.xml16
-rw-r--r--dev-python/recommonmark/recommonmark-0.4.0.ebuild23
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/recommonmark/Manifest b/dev-python/recommonmark/Manifest
new file mode 100644
index 000000000000..dbcfe7bd0fb7
--- /dev/null
+++ b/dev-python/recommonmark/Manifest
@@ -0,0 +1,3 @@
+DIST recommonmark-0.4.0.tar.gz 7112 BLAKE2B d0e0f95f251e859908523c90b012ef2b162823d72b87192651d08a9cb5217a8bf497caf0320cefd3e724f77d3ad4324db446ddb57de55fd308c7739b78f55c04 SHA512 30d900840093c9ee2c1a322aeaba64c06c6f236e4c86a8d7604edc7d9fb0e78d66387f844619364d9253585db3f38d212242d2798153f343bc01ad281c146c9c
+EBUILD recommonmark-0.4.0.ebuild 551 BLAKE2B ec4d65f0f66bc48f3081728404bb1772b93f7dbdadfd69b879e3efb50c979b6c5a8f94036e4e4b89f857b876e8b84fb7f2b97f2faa0372f7441eca4a4e56d839 SHA512 2cc8185c776395839eee64b6bf1beb7e8a1e8e6a6547c6fcef19d977318fd3b85f3c2a9a3fab2513fb462d905d788b8054ddd6cd5a970e4e6dab21f8f01e5a87
+MISC metadata.xml 519 BLAKE2B 8ea8a1e90a05ccb7f78d0de5213fb0ab447a8e8d9ebef7011eb4cb237c909d8bac77319282a76e3db32f58ec0dc6d76f6dfbe3c29c4c71c7f93398d91afffc0c SHA512 83dde1b703e097ce74627ad0139fe6cb97de26cd080bf0b191effe61ff8bd6593bf02a98be1e27ee142520142adebb48c4cb13066cb8d2109ecd642785b78c9e
diff --git a/dev-python/recommonmark/metadata.xml b/dev-python/recommonmark/metadata.xml
new file mode 100644
index 000000000000..308621cf5b42
--- /dev/null
+++ b/dev-python/recommonmark/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This allows you to write CommonMark inside of Docutils and Sphinx
+ projects.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">recommonmark</remote-id>
+ <remote-id type="github">rtfd/recommonmark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/recommonmark/recommonmark-0.4.0.ebuild b/dev-python/recommonmark/recommonmark-0.4.0.ebuild
new file mode 100644
index 000000000000..70feb3a9e234
--- /dev/null
+++ b/dev-python/recommonmark/recommonmark-0.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python docutils-compatibility bridge to CommonMark"
+HOMEPAGE="https://recommonmark.readthedocs.io/"
+LICENSE="MIT"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ <=dev-python/CommonMark-0.5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+IUSE=""