summaryrefslogtreecommitdiff
path: root/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 07:42:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 07:42:23 +0100
commit560c9b9748b885a005f22dac90f6e2622fe9ead5 (patch)
tree9eb65efc966093e8a40428f27a93ca0807af1d29 /dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild
parent38c20fb51b0482ec1b2c2a34ed16227718eac4b2 (diff)
gentoo auto-resync : 30:06:2023 - 07:42:22
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild')
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild
new file mode 100644
index 000000000000..00dffbb4b59c
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/readthedocs-sphinx-ext/
+ https://pypi.org/project/readthedocs-sphinx-ext/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest