summaryrefslogtreecommitdiff
path: root/dev-python/readme/readme-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/readme/readme-0.6.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/readme/readme-0.6.0.ebuild')
-rw-r--r--dev-python/readme/readme-0.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/readme/readme-0.6.0.ebuild b/dev-python/readme/readme-0.6.0.ebuild
new file mode 100644
index 000000000000..8cd6555e5b53
--- /dev/null
+++ b/dev-python/readme/readme-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="a library for rendering \"readme\" descriptions for Warehouse"
+HOMEPAGE="https://github.com/pypa/readme https://pypi.python.org/pypi/readme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}