summaryrefslogtreecommitdiff
path: root/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/re-assert/re-assert-1.1.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/re-assert/re-assert-1.1.0-r1.ebuild')
-rw-r--r--dev-python/re-assert/re-assert-1.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/re-assert/re-assert-1.1.0-r1.ebuild b/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..4826d5328163
--- /dev/null
+++ b/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Show where your regex match assertion failed"
+HOMEPAGE="
+ https://github.com/asottile/re-assert/
+ https://pypi.org/project/re-assert/
+"
+SRC_URI="
+ https://github.com/asottile/re-assert/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest