summaryrefslogtreecommitdiff
path: root/dev-python/rdflib/rdflib-6.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-01 22:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-01 22:14:42 +0100
commit9bc60dddf90169c365a03537991b4d9a5d9b28db (patch)
tree2f2cae7cd5d44dcfd43dc1a4fc81665fba314e8f /dev-python/rdflib/rdflib-6.3.2.ebuild
parentaef01e7679692cb2cf9eca0c03865cfd0a4e33c9 (diff)
gentoo auto-resync : 01:09:2023 - 22:14:42
Diffstat (limited to 'dev-python/rdflib/rdflib-6.3.2.ebuild')
-rw-r--r--dev-python/rdflib/rdflib-6.3.2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/rdflib/rdflib-6.3.2.ebuild b/dev-python/rdflib/rdflib-6.3.2.ebuild
deleted file mode 100644
index ab62e492affd..000000000000
--- a/dev-python/rdflib/rdflib-6.3.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="sqlite?,threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="RDF library containing a triple store and parser/serializer"
-HOMEPAGE="
- https://github.com/RDFLib/rdflib/
- https://pypi.org/project/rdflib/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="examples sqlite"
-
-RDEPEND="
- <dev-python/isodate-1[${PYTHON_USEDEP}]
- >=dev-python/isodate-0.6.0[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- <dev-python/pyparsing-4[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # doctests require internet
- sed -i -e '/doctest-modules/d' pyproject.toml || die
-
- # we disable pytest-cov
- sed -i -e 's@, no_cover: None@@' test/test_misc/test_plugins.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
-
- epytest -m "not webtest"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}