summaryrefslogtreecommitdiff
path: root/dev-python/rapidfuzz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /dev-python/rapidfuzz
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'dev-python/rapidfuzz')
-rw-r--r--dev-python/rapidfuzz/Manifest2
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.6.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 78b727ac014a..86708c465f7e 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,3 +1,5 @@
DIST rapidfuzz-3.5.2.tar.gz 1524315 BLAKE2B 0877a38f3d4229b12944ede688891f5cc401ac644439d93e02a424370ab0e64eebab283de8d921a6e51ff622e425f8ba3b4f13f4eb16f0764440d9c62eca2c50 SHA512 65f7041558c1932ca916faa3c165f62694c7b261d626eb87579e25cd544e9be5bf6da073b6ee621ba2eba4662183315836acb0deda9bb33c1dc927e692438754
+DIST rapidfuzz-3.6.0.tar.gz 1560666 BLAKE2B b0e36a63b68ab2cfdd79c551a9550f6eb763433de4e7f38a81fe8cf05fa2c84a2299f28c2ebeeccfe6ac6d003b181cb810cfb14b578c5b8eade6d77918485278 SHA512 3cd4b85ecd4b6d2fe95e16a7db6d9e936ca82ad8e17a9543609ecd50c14c9a74a3ef6454b1f7a077be0138a14f585ec0729c7e84725fb985595f403dd2705ef2
EBUILD rapidfuzz-3.5.2.ebuild 1471 BLAKE2B 65b5dd6ebbaa9bba15963f6e14990b900ee7f390b4b28f46faf85ea51f4d3b076043d1afb122babc1b2c5d3861e677f49d573780b05b58ab005c87ba2e1e1ff1 SHA512 96f8db074f3e14893980daf6fcbcc61ce59baaab5f29650fd9119e7d391c2d366b6d2b289990f2ca32acb795840e937f12b97b7e71d53e17fbaabce53105e488
+EBUILD rapidfuzz-3.6.0.ebuild 1638 BLAKE2B 9fc6ef1221b30558ef0ad55883566ae3b60389188322634a3674bce0c8eeca906e4ddbb3864efdf5866d59d49a5a83cc7cc88c5633058996c356a1717e06fd27 SHA512 462dfc14de72172b70741c8a215cc07f736e3f5f509462310702911a46c16828bcb1fe0ffba5e74817b90727a25206f5edac0e58a5987f898f1e51eda6fab357
MISC metadata.xml 374 BLAKE2B e6ee89a9850276b8c22c9bc851ebea2cde2ea696d122d70c6465e09a9371c59f81d1976b3253e8ee90afae5e3e30e993481b402058bac0c58ec01f71a0b7c3b4 SHA512 9a39c4bcf8e8de0a6d6a356a9aeb415f8f49667caf5716eee50bf251f1fd53bb076e817fac0b15bf64e65c1b9625c78810da61a5d96b273a20b2669a18084d6e
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.6.0.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.6.0.ebuild
new file mode 100644
index 000000000000..f6910b8aeb0e
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-3.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/maxbachmann/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-3.0.0
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+ # remove bundled libraries
+ rm -r extern || die
+ # force recythonization
+ find src -name '*.cxx' -delete || die
+
+ distutils-r1_src_prepare
+
+ export RAPIDFUZZ_BUILD_EXTENSION=1
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # scikit-build is broken and reuses the same build
+ # https://github.com/scikit-build/scikit-build/issues/633
+ rm -r _skbuild || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}