summaryrefslogtreecommitdiff
path: root/dev-python/raet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/raet
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/raet')
-rw-r--r--dev-python/raet/Manifest2
-rw-r--r--dev-python/raet/files/raet-0.6.8-py310.patch69
-rw-r--r--dev-python/raet/raet-0.6.8-r3.ebuild41
3 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/raet/Manifest b/dev-python/raet/Manifest
index 8778f8fac199..7f11120b3fce 100644
--- a/dev-python/raet/Manifest
+++ b/dev-python/raet/Manifest
@@ -1,4 +1,6 @@
AUX raet-0.6.8-msgpack-1.0.patch 8061 BLAKE2B 90607848542b8ba5a219a872f6f4f4e12546ebf12e1d38cfc3c3259282eda97a641fcfa587646e83ffa5e98d5cc3b0e77c032ebf2358a5cd603e2ac58ad9a114 SHA512 524e2c787386a885796a3666dff792d7e2808585658227acbab51c90c7ebfdfb0435ea67bcdc23e9be6b43364452e23a085d4843e4c1ee1dd576e140007c4293
+AUX raet-0.6.8-py310.patch 1893 BLAKE2B 26dfeb901c64aa8b0c8a63f8be4e02ce65a99eea5e2f81d15be9eacb686a0d13bfe2e41588ed214a78906db2e607e1468f8c477a1c5dbe67cdf7cfae2d16da6a SHA512 d15618790b20e4843ed04a1ffe17acd3b31cf51388a9764c0f8ee33a28d503345dddea8da93418c6b46291ca61e4faf6fe3351935365909d1cfde5fc18d43f6d
DIST raet-0.6.8.tar.gz 807419 BLAKE2B 2370eb55b76a52cf89363f9891a411ea7fa2f27b84bd216c44010fd9afb5dcd9261570f916db00ff7bd922c485cd6123b3a6522154b6e05f7869d7e790177f7b SHA512 01279e7414ec3edc9f2bc0641cb9e0606ebf5700b5ce37a05fd5919f3274b3b43aad64110baf4c4b1fda3843cb1a87b6be4ab592a8f62e82b3a716a86ae61b20
EBUILD raet-0.6.8-r2.ebuild 949 BLAKE2B 63eacb1a51c4e047bc5a189a1183200c3061ebb55dc6050e3bdf5d50a938cb2481cd2ba3af93b2df6df1c8bb99a4b07f785781ccd68a97555a28eeb62ee0282e SHA512 b3f7cd9aaeaab8fd4d694a627229fe49022ffc6250d57978fe9463edbfb4c9d3c20c77efe4e97f60c5ccf15f5c529fafa94b0653e6c6b49752b2515f38d41d2e
+EBUILD raet-0.6.8-r3.ebuild 992 BLAKE2B 96ff2aec6ffc7096789a1a297b115cba164f3da110d215c7170f91f0dfddfa1282b95f0ad3cd687b6bb9b3a64345158938c0192ae38c2b382cb5cedd50e37911 SHA512 c47474a8ab38e789f2b162af25eebeaff5b4264adb389b0ac5e9a812e551fc3c85a74a65011f9573e4ec6296abe733a6e4e06476207a35f029bc8ecc3f24b3da
MISC metadata.xml 475 BLAKE2B a717b6ad3a8b2cdd4b4c48c6fae1226e92080952af627757ac935a6bc8beb3fbf941d6aa0c631281cedadfba5d10d95d6a9b5c8e4a3a47c8da800a7e89fbf8ca SHA512 605d31af6fa66007c18033eea24b7de74b8529996d9a9a19e9e188fd83831f83c5d621aff03e423d25388fca790970de9add12a10ce300aa90bbe08226f6a8e7
diff --git a/dev-python/raet/files/raet-0.6.8-py310.patch b/dev-python/raet/files/raet-0.6.8-py310.patch
new file mode 100644
index 000000000000..94e5287db0b6
--- /dev/null
+++ b/dev-python/raet/files/raet-0.6.8-py310.patch
@@ -0,0 +1,69 @@
+diff --git a/raet/lane/paging.py b/raet/lane/paging.py
+index 5a2f480..e33d95c 100644
+--- a/raet/lane/paging.py
++++ b/raet/lane/paging.py
+@@ -6,7 +6,7 @@ paging module provides classes for RAET UXD messaging management
+ '''
+
+ # Import python libs
+-from collections import Mapping
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/lane/stacking.py b/raet/lane/stacking.py
+index 3969cd9..be88111 100644
+--- a/raet/lane/stacking.py
++++ b/raet/lane/stacking.py
+@@ -11,7 +11,8 @@ import sys
+ import os
+ import errno
+
+-from collections import deque, Mapping
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/road/packeting.py b/raet/road/packeting.py
+index 0675912..078d76d 100644
+--- a/raet/road/packeting.py
++++ b/raet/road/packeting.py
+@@ -6,7 +6,8 @@ packeting module provides classes for Raet packets
+ '''
+
+ # Import python libs
+-from collections import Mapping, deque
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/road/stacking.py b/raet/road/stacking.py
+index 924ae52..4d8670b 100644
+--- a/raet/road/stacking.py
++++ b/raet/road/stacking.py
+@@ -10,7 +10,8 @@ import socket
+ import os
+ import errno
+
+-from collections import deque, Mapping
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
+diff --git a/raet/stacking.py b/raet/stacking.py
+index 0a1743a..9244b66 100644
+--- a/raet/stacking.py
++++ b/raet/stacking.py
+@@ -13,7 +13,8 @@ import sys
+ if sys.version_info > (3,):
+ long = int
+
+-from collections import deque, Mapping
++from collections import deque
++from collections.abc import Mapping
+ try:
+ import simplejson as json
+ except ImportError:
diff --git a/dev-python/raet/raet-0.6.8-r3.ebuild b/dev-python/raet/raet-0.6.8-r3.ebuild
new file mode 100644
index 000000000000..f41b578b6ce5
--- /dev/null
+++ b/dev-python/raet/raet-0.6.8-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
+HOMEPAGE="https://github.com/RaetProtocol/raet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/libnacl-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-2.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/raet-0.6.8-msgpack-1.0.patch"
+ "${FILESDIR}/raet-0.6.8-py310.patch"
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "/setuptools_git/d" -i setup.py || die
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
+ popd || die
+}