summaryrefslogtreecommitdiff
path: root/dev-python/qtsass/qtsass-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /dev-python/qtsass/qtsass-0.4.0.ebuild
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'dev-python/qtsass/qtsass-0.4.0.ebuild')
-rw-r--r--dev-python/qtsass/qtsass-0.4.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/qtsass/qtsass-0.4.0.ebuild b/dev-python/qtsass/qtsass-0.4.0.ebuild
new file mode 100644
index 000000000000..6d420d1107df
--- /dev/null
+++ b/dev-python/qtsass/qtsass-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Compile SASS files to Qt stylesheets"
+HOMEPAGE="
+ https://github.com/spyder-ide/qtsass/
+ https://pypi.org/project/qtsass/
+"
+SRC_URI="
+ https://github.com/spyder-ide/qtsass/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/libsass-python-0.22.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest