summaryrefslogtreecommitdiff
path: root/dev-python/qtconsole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 09:09:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 09:09:19 +0000
commit1ab8c7f6ed10f981d767a0acc2f420cf86775f12 (patch)
tree44eb556f62eeb50b980ae79712fa5087c2c7e3b0 /dev-python/qtconsole
parent29badda007a3bcd85bb351f602790eb3b8922448 (diff)
gentoo auto-resync : 02:11:2022 - 09:09:18
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest2
-rw-r--r--dev-python/qtconsole/qtconsole-5.4.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 69a9d7b1a960..9f5777b34db4 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,3 +1,5 @@
DIST qtconsole-5.3.2.tar.gz 430792 BLAKE2B 246dadaab92851f8da65dfa4c7e80390defeb0855fdb3ea5ef6aab96bf56b28597dc65d7cb4fc95f0f795a19f4b826d0ec1e1e0b025f4fa49d4d5a78473a2b29 SHA512 715e7e4b185a656f395a30c575e8996271cea4672871d9471c74a13364be1ef0fe0e63951e8f52f10b9c887592dc899c399ae82e09f9934492d13119b1154796
+DIST qtconsole-5.4.0.tar.gz 431119 BLAKE2B 48348b400a9b594bd028d3905719f2d67f6c9281df99863f3d0d87cf83162c91ede3e65529a8efd3bff62ad3ea343cc4ee7ea028913cd5bf7e48d0c493930445 SHA512 c25a381d8494c64d63e379c1dd5a44c1945e773b87b9a27f8494905e7eca24c6381ec5b9792d9a57ac41b14137ce238795a5ff8d83d1b6ddaa62603e7d9ab165
EBUILD qtconsole-5.3.2.ebuild 1593 BLAKE2B 2e4cf9755082be272477aa5aafdecaa05df29d2f58d90c0c95467654f20c4946b95ca9278fa98879c1417f7c50e78245c72ae31202edcc33582f21646d84ee0c SHA512 48c2ff2ead0f7f0c3f463c8357ac52c1fc3b7bd0883ce0ee1784fd0f26774bbf80276aa1dc107cfacef8b93b1881636bbc953712f82bf078b65fecbb583855ff
+EBUILD qtconsole-5.4.0.ebuild 1596 BLAKE2B 8f4f6925dfea93f92196cc0fa82e1961f8cab68270626554d2cee12629f82d722b67188af40faad657a6ab5791f5e5f94cfd865cd6ce60d5ad039f26e7310bde SHA512 f5352d3cab225a773aae4b6edc5cb702ac6de71eeab93204ffa1570febf1be05c100b4a21e2d0e22f091028cc164f0966d2f05f2c4a1a8373cf1a8e3dd2548aa
MISC metadata.xml 690 BLAKE2B f2ddc6515f66ac4549e99bd6f152c16431875508bf12b6319e0e6a2b1596d86abc50b87ee424d3876eb55e92d1a506ade6567cbad535b4b2b54fad924a1891a7 SHA512 28bb7360ac7775d9c72c4d0f34d4c9a35c63905c4e870722236cc6c66e98f6c0eb165c8d7a9ce28948b25808a053dd1bb667d1f4783ca95319bb216310dc9f60
diff --git a/dev-python/qtconsole/qtconsole-5.4.0.ebuild b/dev-python/qtconsole/qtconsole-5.4.0.ebuild
new file mode 100644
index 000000000000..2a5b0bb408d9
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+# The test suite tests both against pyqt5 *and* pyside2
+BDEPEND="
+ test? (
+ dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ EPYTEST_IGNORE=(
+ qtconsole/tests/test_00_console_widget.py
+ qtconsole/tests/test_jupyter_widget.py
+ )
+ epytest
+}