summaryrefslogtreecommitdiff
path: root/dev-python/qtawesome/qtawesome-1.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 06:04:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 06:04:07 +0000
commit27ecae7b5eb4c80903720ae76a54a68af3447c31 (patch)
tree90b91404883f7c53646987409a6636aa44549bd9 /dev-python/qtawesome/qtawesome-1.2.3.ebuild
parent71e206c31e948709a88fafc342bd2d8695942aa5 (diff)
gentoo auto-resync : 10:03:2023 - 06:04:07
Diffstat (limited to 'dev-python/qtawesome/qtawesome-1.2.3.ebuild')
-rw-r--r--dev-python/qtawesome/qtawesome-1.2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/qtawesome/qtawesome-1.2.3.ebuild b/dev-python/qtawesome/qtawesome-1.2.3.ebuild
new file mode 100644
index 000000000000..ef05bcf99451
--- /dev/null
+++ b/dev-python/qtawesome/qtawesome-1.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Enables iconic fonts such as Font Awesome in PyQt"
+HOMEPAGE="
+ https://github.com/spyder-ide/qtawesome/
+ https://pypi.org/project/QtAwesome/
+"
+SRC_URI="$(pypi_sdist_url --no-normalize QtAwesome)"
+S="${WORKDIR}/QtAwesome-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-fonts/fontawesome
+ dev-python/QtPy[pyqt5(+),gui,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ # Tests fail with pyside2, so depend on QtPy[pyqt5] and explicitly run
+ # the tests with pyqt5
+ PYTEST_QT_API="pyqt5" epytest || die "Tests failed with ${EPYTHON}"
+}