summaryrefslogtreecommitdiff
path: root/dev-python/qscintilla-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /dev-python/qscintilla-python
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/Manifest2
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/Manifest b/dev-python/qscintilla-python/Manifest
index 5df119a2c39c..2bd5bc2d9305 100644
--- a/dev-python/qscintilla-python/Manifest
+++ b/dev-python/qscintilla-python/Manifest
@@ -1,3 +1,5 @@
DIST QScintilla_gpl-2.10.3.tar.gz 2721287 BLAKE2B cc85eea17e563ae5f4a130d26ca88bec3e1a6cbff7bc0af096c63789384d03149105641d6324f53b37a2bd8ab4681a285ccb76e6063a06e5db30d070d3fd8219 SHA512 a1b9d6869797ec074e4e0727164804779792fb77b2230aae80e6d6b5fb3a3ff9d84e17d775d18ab74c97b78bac454511fd2cb49be1fa36f71d9097abf88045b6
+DIST QScintilla_gpl-2.10.4.tar.gz 2721322 BLAKE2B df50dd0a34db96dd57147ddc399d4a30751b1bb4922dc1b8b3c3c1989e810937dc8345f92128e8a606b1edc04fde4b930a424ab8344818c9899c8fe496793a77 SHA512 dee6684f68173784d098931554c839a30e129b89f980cd9704f818c44eb7023199bd3682e4b342091fa3e0ce577ec576d34046477bdd1d7fc58ca5dd2ba947a3
EBUILD qscintilla-python-2.10.3.ebuild 1528 BLAKE2B 29f01e825027fb0c7e7a130ae9b2474c920a69bbeb7662a0a08cdedd308ec8eba446762a4a7dd9508417338feee6f798f33a50a2ccdfb76fe217a3b51a6d2202 SHA512 4822e5bd19abcd917e6bda804f08318ccd60bbc55f7b191865d24590c73768ea059aa91f985f14ba72dd2e436c01e11e22342948b010e102f785c1b3142f1e94
+EBUILD qscintilla-python-2.10.4.ebuild 1530 BLAKE2B 468794c93a97f20d91bbe6bcabfdb82a978934321be5afad31a81f19bae7877b21644648c7490407f6e4cae72a7816d0503f9cfa90ff688f474a83220293568d SHA512 7c0fad99f6959f05258a6f5dba489071f0cd53982fdcde2967b69d8589f6031e24e76ff8172453caae1f03e27ebf61e21787ca5cb625f5c4a1d2ef150e2003d6
MISC metadata.xml 666 BLAKE2B ca3cfedb72c4bc624270f669034a78c1fd41ed48a261b6d2fd84ee9994d130d1b558578925028eed57a85db021f3cfe4b70e51eeb9a42f4f71392994f7bade82 SHA512 f78ce18443d32b17307e96f8177bc5fb46f5b9f6b4d797e79dcacb6eb76bba578f7d666469576bd5e326717bcd9167fe34a5e1bd1ead5679619816ef8f0363da
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
new file mode 100644
index 000000000000..ab5f9388efba
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla_gpl-${PV/_pre/.dev}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ ~x11-libs/qscintilla-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_configure() {
+ configuration() {
+ # Fix out-of-source build and installation of .sip files
+ ln -s "${S}"/sip || die
+
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --pyqt=PyQt5
+ --qmake="$(qt5_get_bindir)"/qmake
+ --sip-incdir="$(python_get_includedir)"
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain, build flags, and prevent stripping
+ eqmake5 -recursive
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}