summaryrefslogtreecommitdiff
path: root/dev-python/qpageview/qpageview-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/qpageview/qpageview-0.6.2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/qpageview/qpageview-0.6.2.ebuild')
-rw-r--r--dev-python/qpageview/qpageview-0.6.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/qpageview/qpageview-0.6.2.ebuild b/dev-python/qpageview/qpageview-0.6.2.ebuild
new file mode 100644
index 000000000000..90d467d7a46c
--- /dev/null
+++ b/dev-python/qpageview/qpageview-0.6.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Page-based viewer widget for Qt5/PyQt5"
+HOMEPAGE="https://qpageview.org/"
+SRC_URI="https://github.com/frescobaldi/qpageview/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+# GPL-2+ added here because of https://github.com/frescobaldi/qpageview/issues/15
+# Should be GPL-3+ once cleared up
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/PyQt5[gui,printsupport,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/python-poppler-qt5[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "Printing support" dev-python/pycups
+}