summaryrefslogtreecommitdiff
path: root/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild')
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild b/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild
new file mode 100644
index 000000000000..25c68c9ea48f
--- /dev/null
+++ b/dev-python/qdarkstyle/qdarkstyle-3.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+MY_PN="QDarkStyle"
+
+DESCRIPTION="A dark style sheet for QtWidgets application"
+HOMEPAGE="https://github.com/ColinDuquesnoy/QDarkStyleSheet"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: Figure out how to get this to work
+# Please pass a palette class in order to create its qrc file
+# This appears to be fundamentally broken: test calls create_qss() without
+# argument and that function does sys.exit(1) if the argument is None.
+RESTRICT="test"
+
+RDEPEND=">=dev-python/QtPy-1.7[gui,${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/qtsass[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.7[gui,testlib,${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Retrieve detailed system information and report bugs upstream" dev-python/helpdev
+ optfeature "qdarkstyle.utils" dev-python/qtsass dev-python/watchdog
+}